Probleme de connexion Access

Signaler
Messages postés
17
Date d'inscription
lundi 28 février 2005
Statut
Membre
Dernière intervention
26 mai 2005
-
Messages postés
1
Date d'inscription
jeudi 14 avril 2005
Statut
Membre
Dernière intervention
5 décembre 2005
-
lu!

bon j'ai un probleme voila le code que j'utilise pour me connecter

OleDbConnection conn = new
OleDbConnection(@"provider=Microsoft.Jet.OLEDB.4.0;Data Source="+bdPath
+ "User Id=Administrateurs;Password=pass");

et je recupere un vieux message tout moche qui me dit:



Impossible de démarrer votre
application. Le fichier d'informations du groupe de travail est absent
ou ouvert en mode exclusif par un autre utilisateur.



et la je comprends pas ce que je peux faire...

est ce que quelqu'un peut me fournir une reponse ou m'expliquer pourkoi g ce message...

Merci ;)


Just nuke it

6 réponses

Messages postés
12
Date d'inscription
mardi 8 février 2005
Statut
Membre
Dernière intervention
20 mai 2005

selon moi tu doit avoir ta base de donnee access ouvert par un autre prog.

quitte tout les prog en cour et retente

sinon ta pas oublier un " ; "

OleDbConnection conn = new OleDbConnection(@"provider=Microsoft.Jet.OLEDB.4.0;Data Source="+bdPath + ";User Id=Administrateurs;Password=pass");
Messages postés
219
Date d'inscription
samedi 21 août 2004
Statut
Membre
Dernière intervention
17 juillet 2007
2
c'est exacte ce qu'il dit
va redemarrer ton pc pour etre sur que tu as tous fermer

Dibou
Messages postés
17
Date d'inscription
lundi 28 février 2005
Statut
Membre
Dernière intervention
26 mai 2005

non ca resout rien au probleme meme avec les ";" au bon endroits meme avec un reboot...etc

La je craque...

Just nuke it
Messages postés
3466
Date d'inscription
lundi 16 octobre 2000
Statut
Modérateur
Dernière intervention
30 octobre 2008
54
Tu as essayé de coder la connectionString en dur, avant de la construire dynamiquement ?


Mx
Messages postés
433
Date d'inscription
samedi 26 avril 2003
Statut
Membre
Dernière intervention
4 décembre 2009
1
Hello,

tout simplement il y a un verrou sur la base en mode exclusif.

Dans le meme répertoire que taon fichier MDB il doit y avoir un fichier LDB( lock data base).

Supprimme ce fichier et reteste ta connection.
Messages postés
1
Date d'inscription
jeudi 14 avril 2005
Statut
Membre
Dernière intervention
5 décembre 2005

Je dois effectuer un site internet pour un travail dans un cours d'info. Mon site tourne sans problème sur ma machine, mais une fois sur le serveur j'ai un problème avec ma Base de donnée. Je suppose qu'il doit s'agir d'un problème de chaine de connexion.Ma bd se trouve dans un répertoire Databases et mon site dans un autre répertoire.Voici à quoi ressemble ma chaine de connexion.


cnx="Provider=Microsoft.Jet.OleDB.4.0;User ID=Admin;Data Source="+Server.MapPath("../")+"/databases/resultats.mdb";Jet OleDB;

Es ce que qq pourrait me dire si il y a une erreure de syntaxe dans cette chaine.
Merci d'avance.