Crystal report (ne trouve pas crystaldecisions.vsdesigner) [Résolu]

Hep8 8 Messages postés dimanche 11 avril 2004Date d'inscription 6 avril 2005 Dernière intervention - 6 avril 2005 à 12:05 - Dernière réponse : Hep8 8 Messages postés dimanche 11 avril 2004Date d'inscription 6 avril 2005 Dernière intervention
- 6 avril 2005 à 15:10
Je dois utiliser crystal report, comme c'est ma premiere utilisation de ce soft, j'utilise ce tuto:

http://neo.developpez.com/tutos/CR/csharp/
(merci Arthenius)

Mais j'ai un probleme lorsque je crée un nouvel objet "Etat Crystal report."
Je lance le "Expert Etat" comme di dans le tuto,



suite tuto: "Dans l'onglet "Données" développer l'arbre ADO.NET, puis le dataset "DatasetTypEtat""
Je n'ai pas les onglet dont il parle, mais je suis dans "l'assitant de création d'état standart", partie "Données" et je vois bien mon dataset dans "ADO.NET dataset", donc malgrés l'interface différente par raport au tuto, tout a l aire de fonctionner.

Seulment c'est a ce moment qu'il faut ajouter les champs des tables souhaité, et moi sous mon dataset il est marqué: "aucun élément trouvé".
La connexion marche pourtant trés bien dans mon dataset.
quand je double clic sur le dataset (toujours dans l'"Expert Etat") il me propose alors d'entrer les info. de connexion...
Je peux alors choisir:
- utiliser les classe du projet, il me propose mon dataset
Avec cette option , message d'erreur: "echec de la connexion, le fichier ou l'assembly
crystaldecisions.vsdesigner ou l'une de ses dépendance est introuvable."
- ou rechercher sur le disque (un fichier XML)
et pour cette option: echec de la connexion.

Si quelqun peut me dire ce qui se passe, ce serrait sympa!

info:
crystal report 9
VS.NET 2003
bd : sqlserver
os: xp pro

Hep, toi la bas!
Afficher la suite 

2 réponses

Répondre au sujet
Hep8 8 Messages postés dimanche 11 avril 2004Date d'inscription 6 avril 2005 Dernière intervention - 6 avril 2005 à 15:10
+3
Utile
Tient, j'ai trouvé ! Et c'était très con ... moi plus que la solution...

en gros, si quelqun d'autre a le "probleme":

Field explorer, clic droit sur database field, database expert, derouler OLE DB (ADO) et etablir une nouvelle collection

La suite est dans le tuto...


bon ben je

Hep, toi la bas!
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de Hep8
Hep8 8 Messages postés dimanche 11 avril 2004Date d'inscription 6 avril 2005 Dernière intervention - 6 avril 2005 à 15:10
0
Utile
Hep, toi la bas!
Commenter la réponse de Hep8

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.