Recherche aide pour utilisation des control utilisateurs

Signaler
Messages postés
10
Date d'inscription
mercredi 19 février 2003
Statut
Membre
Dernière intervention
7 novembre 2007
-
Messages postés
10
Date d'inscription
mercredi 19 février 2003
Statut
Membre
Dernière intervention
7 novembre 2007
-
Bonjour à tous et merci pour ce site ...

Généralement, je pose rarement de question parceque je trouve toujours mon bonheur sur ce site ou dans les MSDN ...

Mais là je suis bloqué par une incomprehension ...

J'aimerais utiliser un control utilisateur regroupant un certain nombre de Shape (Line,Square,circle, etc) sur lesquels j'ai des propriétés, methodes et events ... rien d'extraordinaire ...

Mon souci est que lorsque je modifie les propriétés (Genre Backcolor) de l'un ça change les propriétés de tous les tous les autres

A savoir que ce control est ajouté dynamiquement sur mon interface ... lorsque j'initialise 1 control ça re-initialise tous les autres ...

J'ai certainement oublié un truc ... d'ou AU SECOUR !!!

Merci ..

PS: Si vous avez une bonne adresse d'un tuto sur l'utilisation des Control utilisateur sous VB6 je suis prenneur ...

2 réponses

Messages postés
115
Date d'inscription
dimanche 6 avril 2003
Statut
Membre
Dernière intervention
29 juin 2012

Salut c JP
je débute dans les contrôls, alors ma question est peut être bêête...
est ce que tu as créé un Set/Let/Get BackColor pour chaque object ?

Bidouille ... Débrouille ... Euuh !?... m' Embrouille .!!! @+ JP
Messages postés
10
Date d'inscription
mercredi 19 février 2003
Statut
Membre
Dernière intervention
7 novembre 2007

Alors étant novice sur l'utilisation des controls ... j'ai effectivement fait un set/let/get sur le backcolor et uniquement sur le usercontrol ...

Dans mon usercontrol, je modifie les backcolor de mais shape ... c a d que si je change le backcolor de mon Usercontrol ... je change toutes les shapes contenu dans celui -ci ...

C peut etre là mon erreur, j'aurais peut etre du faire un set/let/get sur tout mes shapes?

Koi kil en soit aprés mure reflexion je crois que c l'ensemble de mon Usercontrol qui est disfonctionnant ... toutes mes propriétés ne conserve pas leur valeur unique (comme pour un objet classique) ... j eme retrouve à la fin de l'affichage dynamique des objets ayant tous les mêmes valeurs ...

Argh ... là va falloir que je trouve un tuto serieux sur le dev des usercontrol dans VB ... parceque là je dois pas faire ce qui est normal