DataEnvironnement et DataGrid

cs_polac Messages postés 11 Date d'inscription lundi 22 juillet 2002 Statut Membre Dernière intervention 17 octobre 2002 - 26 août 2002 à 16:53
cs_polac Messages postés 11 Date d'inscription lundi 22 juillet 2002 Statut Membre Dernière intervention 17 octobre 2002 - 27 août 2002 à 09:57
Salut à tous.

J'essaye de remplir mon DataGrid avec une requete SQL (avec paramètre).
La requete est dans mon DataEnvironnement.

Dans le DataEnv :
select codesociete from societe where codetest=?

Dans la Form :
DataEnv.Command Variable

Quand j'execute le code, il ne m'affiche rien du tout.

Par contre, si dans le DataEnv, je paramètre la valeur de la variable, là ça fonctionne.

Comprend po....

Merci de votre aide

le_polak - L'homme qui vient du froid

2 réponses

cs_dido Messages postés 41 Date d'inscription mardi 14 mai 2002 Statut Membre Dernière intervention 17 janvier 2003
26 août 2002 à 21:41
Salut,

Il faut que ta requete soit :

select codesociete, codetest from societe
(pas de where...)

ensuite, ds ta procedure de chargement datagrid (on va dire que c ds le load de ta form)

Private Sub Form_Load()
DataEnvironment1.rsCommand1.Filter = "Codetest=3"
End Sub


dans ton grid tu vas avoir donc codesociete et codetest qui est egale à 3 (a toi de cacher la colonne codetest)

dis moi si tu as reussi

@+
0
cs_polac Messages postés 11 Date d'inscription lundi 22 juillet 2002 Statut Membre Dernière intervention 17 octobre 2002
27 août 2002 à 09:57
Un grand merci à toi pour le conseil. Ca marche au poil!!!
Tchao et @++

le_polak - L'homme qui vient du froid
0
Rejoignez-nous