Erreur application serveur indisponible [Résolu]

Signaler
Messages postés
11
Date d'inscription
mercredi 15 septembre 2004
Statut
Membre
Dernière intervention
3 mars 2005
-
aspchallenge
Messages postés
11
Date d'inscription
mercredi 15 septembre 2004
Statut
Membre
Dernière intervention
3 mars 2005
-
Bonjour,

J'ai installé IIS, puis le framework sdk pour faire de l'asp.net.
J'ai fait un test avec une page toute simple et cela fonctionnait bien.

J'ai donc installer web matrix et MSDE par la suite.
et bien sur redemarrer mon pc.

Et maintenant losrque je veux afficher ma page de test du depart je recois le message d'erreur "application web indisponible." Consulter le journal des erreurs.
J'ai pu remarquer qu'un compte aspnet a ete cree et que selon mais recherche j'aurais un probleme de droit d'acces au rep virtuel. mais je ne trouve pas de solution, pourtant ce compte a les droits administrateur. Je pense que l'erreur est impossible de demarrer asp.web.exe, mais je ne suis pas sur parce que je nesais pas consulter le journal des erreurs.
Merci de votre aide.

Benjamin.

4 réponses

Messages postés
6827
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
17
asp.web.exe je ne connais pas :-/



pour consulter le log : tu tapes ca dans demarrer > executer :
compmgmt.msc \s et la dans outils systeme, tu vas arriver à trouver ce
qu'il y a.



Sinon tu obtiens la page enfaisant comment ? en aller sous webmatrix
puis F5 ? ou alors directement par http://localhost/truc.aspx



pour avoir des détails sur l'erreur, met l'attribut mode à RemoteOnly, dans la balise costumerrors dans le web.config



pour generer automatiquement le fichier web.config, va dans webmatrix je pense qu'il doit y avoir ca










<hr>

Cyril - http://Hoshimi.CodeS-SourceS.fr
Messages postés
6827
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
17
T'as pas trouvé les logs d'erreur dans

Gestion de l'ordinateur > outils systeme > observateur d'evenements > ...



Pour ce qui est de MSDE, l'installation est un calvaire mais heureusement il existe une vidéo qui détail comment l'installer, regarde dans la section vidéo du site Quand tu l'installes tu dois définir un mot de passe, nom de connexion etc...



Pour ce qui est de la chaine de connexion, va donc faire un tour sur
www.connectionStrings.com tu trouveras plein de chaine type pour tes
connection.



Pour ce qui est du serveur SMTP, il faut que ce service soit installer
sur ton PC (ajout suppression de programmes puis ajout de composant
windows) ensuite je ne sais plus si par défaut tu dois configurer
quelque chose ou pas, regarde du coté de www.asp-php.net, cela
m'etonnerais qu'il n'y ait pas un article sur la configuration du
service SMTP.



Sinon pour ce qui est d'enregistrer tout ca, dans la base de données,
j'ai fait une source qui permet d'enregistrer des variables dans le
web.config via les balises Cyril - MCP ASP.net
Webmaster de : Hoshimi.CodeS-SourceS.fr
Messages postés
11
Date d'inscription
mercredi 15 septembre 2004
Statut
Membre
Dernière intervention
3 mars 2005

Salut,

J'ai bien effectuer la ligne de commande que tu m'a indiquer et je me suis retrouvé dans la gestion del'ordinateur. J'ai pu voir qu'il y avait pleins de compte dont j'ignorais l'existance. Notament un compte IUSR_Mon nom de PC, que l'on retrouve dans la securite de IIS.

Pour te repondre, j'obtiens ce message d'erreur en passant par http://localhost/page.aspx
Mais pour etre plus clair en fait j'essaie de suivre les instruction d'un livre qui s'appelle les cahiers des programmeurs (www.savonsdusoleil.com) et que je pense tu dois connaitre. C'est une etdue de cas et pour demarrer, il faut executer un script oqsl qui creer la BD et les requetes. Mais apres il faut configurer la chaîne de connexion, les mots de passe et le nom du serveur SMTP dans le fichier web.config, et je ne vois pas a quelle mot de passe il faut se referer ni ou ils sont. Je pense que mon probleme vient plus de la maintenant puisque j'ai reussi a refaire fonctionner une page toute simple en bidougnant les droit des comptes et la securite de IIS.(meme si cela doit pas etre tres accademique).
En resumer je ne sais pas configuerer la chaine de connexion et les mots de passe sous le fichier web.config.

Benjamin.
Messages postés
11
Date d'inscription
mercredi 15 septembre 2004
Statut
Membre
Dernière intervention
3 mars 2005

Ok, merci pour toutes ces infos, c niquel, en effet c'etait une tannee pour MSDE. Et g enfin trouvé le journal des erreurs.
Bref tout fonctionne et je peux attaquer enfin les exemples du livre.

Merci encore pour ton aide et ta patience.

Benjamin.