Image OLE

Messages postés
2
Date d'inscription
jeudi 18 juillet 2002
Statut
Membre
Dernière intervention
6 août 2002
-
Messages postés
1
Date d'inscription
samedi 26 octobre 2002
Statut
Membre
Dernière intervention
27 octobre 2002
-
j'ai un souhait simple, mais je suis incapable de le réaliser:
-j'ai créer sous access une base contenant une image bitmap
-je souhaite l'affiche sous VB, mais je ne sais pas le faire.
- j ai essayé :
Me.OLE_picto.picture = l_rst![pictogramme]
et meme
'Me.OLE_picto =LoadPicture( l_rst![pictogramme])
mais ce ne marche pas
Merci d'avance

1 réponse

Messages postés
1
Date d'inscription
samedi 26 octobre 2002
Statut
Membre
Dernière intervention
27 octobre 2002

Bonsoir,

J'ignore exactement quels sont vos besoin, mais il est possible d'utiliser un objet DATA qui va faire le lien entre la BD et l'objet OLE.
Dans l'objet DATA il y a une propriete du nom de DatabaseName qui faut initialiser avec le chemin d'acces de la BD, soit par la propriete directement ou par le code Me.OLE_picto.DatabaseName="C:\.....\BD.mdb".
Dans l'objet OLE il faut initialiser 2 proprietes (DataSource et DataField). Pour ce qui est du DataSource je ne sais pas comment l'initialiser autrement que par la propriete directement, qu'il faut initialiser avec le nom de l'odjet DATA. Pour le DataField, le code est tout simplement Me.OLE_picto.DataField="pictogramme", ou bien entendu par la propriete.

Voila c'est tout, j'espere que cela pourra vous aider.

-------------------------------
Rponse au message :
-------------------------------

j'ai un souhait simple, mais je suis incapable de le réaliser:
-j'ai créer sous access une base contenant une image bitmap
-je souhaite l'affiche sous VB, mais je ne sais pas le faire.
- j ai essayé :
Me.OLE_picto.picture = l_rst![pictogramme]
et meme
'Me.OLE_picto =LoadPicture( l_rst![pictogramme])
mais ce ne marche pas
Merci d'avance