Erreur Socket [Résolu]

Messages postés
78
Date d'inscription
jeudi 17 février 2005
Dernière intervention
26 décembre 2005
- - Dernière réponse : sosodef88
Messages postés
78
Date d'inscription
jeudi 17 février 2005
Dernière intervention
26 décembre 2005
- 22 févr. 2005 à 12:09
bonjour j'utilise le composant TClientSocket et après plusieurs (de 4 a 6) connexion/déconnexion (toute les 3 ou 4 seconde) le composant n'arrive plus a se connecter.... que dois-je faire ?

voila mon prog

1) socket.open;
2) envoi des données
3) réception des données
4) socket.close;
5) retour a l'étape 1

ps: des fois ca fonctionne ca va jusqu'a 10

Ce que je pensais faire c'est: faire une pose de 0,5 seconde entre chaque étape mais je ne connais pas bien delphi .... Merci pour vos réponses
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
78
Date d'inscription
jeudi 17 février 2005
Dernière intervention
26 décembre 2005
3
Merci
Excusez, je pensais pas qu'un simple application.ProcessMessages aurais suffit ;)

Merci sosodef88 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources a aidé 105 internautes ce mois-ci

Commenter la réponse de sosodef88

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.