Probleme utilisation DLL avec Builder

Signaler
-
Messages postés
2
Date d'inscription
vendredi 18 avril 2003
Statut
Membre
Dernière intervention
5 février 2005
-
Bonjour, je me permet de poser un message car malgré le nombre de tutoriaux sur ce sujet , je n'arrive pas à m'en sortir et le chat #programmation ne me renseigne pas plus (Merci les gars..).
Je vous expose mon probleme.
Je possede une DLL ainsi que les fichiers ".h" et ".lib" qui lui correspondent.
Je fait donc la manipulation implib de mes fichiers, j'inclue a mon projet le .lib et j'ajoute la ligne #include mon ".h".
J'appelle une fonction de ma dll mais a l'edition des liens, au
surprise!!! On ne trouve pas ma fonction!!!

[Linker Error] Unresolved external 'HpibOpen' referenced from C:\PROGRAM FILES\BORLAND\CBUILDER6\PROJECTS\UNIT1.OBJ

Que dois-je donc faire?

Merci de vos reponses... Je peut mettre mes librairies a votre disposition pour que vous fassiez vos testes et concluez peut etre au fait qu'elles ne fonctionnent pas tout simplement.

[mailto:oosylvainoo@aol.com oosylvainoo@aol.com]

Votre Souillasse dévouée!

2 réponses

Messages postés
21042
Date d'inscription
jeudi 23 janvier 2003
Statut
Modérateur
Dernière intervention
21 août 2019
27
Faut indiquer le lib a ton linker, regarde dans C++ Builder les options.

ciao...
BruNews, MVP VC++
Messages postés
2
Date d'inscription
vendredi 18 avril 2003
Statut
Membre
Dernière intervention
5 février 2005

Le .lib est ajouté avec Projet/ajouter au projet/ mon .lib
Et ca ne marche pas..

Votre Souillasse dévouée!