AttachMovie

Résolu
stemou Messages postés 6 Date d'inscription jeudi 3 février 2005 Statut Membre Dernière intervention 23 février 2005 - 3 févr. 2005 à 13:57
stemou Messages postés 6 Date d'inscription jeudi 3 février 2005 Statut Membre Dernière intervention 23 février 2005 - 8 févr. 2005 à 16:49
Mon probléme est le suivant je récupére l'id du moviclip que
je veux affiché d'un fichier txt , mais attachMovie n'accepte
pas que je mette une variable contenant cet id.
comment faire pour afficher dinamiquement une image (mc).
voici le code:

stop();
var mavar:LoadVars = new LoadVars();
mavar.load("./montexte.txt");
mavar.onLoad=function(success){
if(success){
var i =mavar.img;
trace(typeof(i))
_root.attachMovie(i,"photos1",1);
photos1._x=160;
photos1._y=20;

}
}

et le fichier text:
img=image1
Merci de votre aide!

3 réponses

stemou Messages postés 6 Date d'inscription jeudi 3 février 2005 Statut Membre Dernière intervention 23 février 2005
8 févr. 2005 à 16:49
Après quelques tests ce code ci marche!
mai il me parais identique au premier !!
le code:
stop();
var mavar:LoadVars = new LoadVars();
var mytxt:String;
var success:Boolean;
mavar.load("./info1.php");
mavar.onLoad=function(success){
if(success){
var i=mavar.img;

trace(typeof(i))
_root.attachMovie(i,"photos1",1);
trace (i);
}
}
3
pegase31 Messages postés 6138 Date d'inscription dimanche 21 décembre 2003 Statut Modérateur Dernière intervention 4 septembre 2013 11
3 févr. 2005 à 14:23
essaye avec :

_root.attachMovie(this[i],"photos1",1);
0
stemou Messages postés 6 Date d'inscription jeudi 3 février 2005 Statut Membre Dernière intervention 23 février 2005
3 févr. 2005 à 15:49
Nom ca ne foctione pas !
il n'y à pas de message d'erreur mai pas d'image afficée !
0
Rejoignez-nous