Utilisation de CDO sur Windows Server 2003

jcohen Messages postés 6 Date d'inscription mercredi 11 juin 2003 Statut Membre Dernière intervention 28 janvier 2005 - 28 janv. 2005 à 13:55
cs_Nurgle Messages postés 1642 Date d'inscription samedi 6 novembre 2004 Statut Membre Dernière intervention 28 avril 2011 - 28 janv. 2005 à 18:00
Bonjour àtous,
PEtit soucis, j'ai un formulaire dont je récupère le contenu par amil via CDONTS. Changement d'hébergeur et passage sous Win 2003 donc changement de méthode car CDONTS ne fonctionne plus. J'essaye d'utiliser CDO mais sans succès, ce n'est aps faute de me documenter, l'objet est bien créé (il est installé sur le serveur) mais impossible d'envoyer le mail !
A mon avis l'erreur vient de l'authentification sur le serveur SMTP distant (wanadoo).
Mon site est hebergé chez Verio.
Voici le code :
<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="[mailto:contact@toto.org contact@toto.org]"
myMail.To="[mailto:toto@hotmail.com toto@hotmail.com]"
myMail.TextBody="This is a message."
myMail.Configuration.Fields.Item _
("http://schemas.microsoft.com/cdo/configuration/smtpserver") _
="smtp.wanadoo.fr"
'Server port
myMail.Configuration.Fields.Item _
("http://schemas.microsoft.com/cdo/configuration/smtpserverport") _
=25
myMail.Configuration.Fields.Update
myMail.Send
%>
Si qq1 a une piste, parce que la je désepsère...
Merci d'avance
Jay

1 réponse

cs_Nurgle Messages postés 1642 Date d'inscription samedi 6 novembre 2004 Statut Membre Dernière intervention 28 avril 2011 5
28 janv. 2005 à 18:00
Salut

Voilà comment envoyer un mail sous Windows 2003 sans composant (et le mieux, c'est que ça marche !!) : http://www.aspfr.com/code.aspx?id=29083

@+

Nurgle
C'est une grande folie que de vouloir être sage tout seul !
Rejoignez-nous