Playliste MP3

cs_jumpin Messages postés 13 Date d'inscription mercredi 19 mai 2004 Statut Membre Dernière intervention 6 juin 2006 - 24 janv. 2005 à 22:28
cs_jumpin Messages postés 13 Date d'inscription mercredi 19 mai 2004 Statut Membre Dernière intervention 6 juin 2006 - 27 janv. 2005 à 09:13
bonjour!



j ai un lecteur mp3 en flash qui charge les mp3 par l'intermédiaire
d'un fichier php. lorsque je sélectionne le mp3 à jouer, je clic sur le
btn play et le morceau commence à jouer. donc tout va bien! mais
parfois, chez certaines personnes avec internet explorer, lorsqu'elle
clic sur play, le navigateur leur demande si elles veulent télécharger
le morceau, ce qui n est évidemment pas le but!

je ne sais pas pour quelles raisons ceci se passe, car chez moi, que ce
soit avec firefox, explorer, opéra... ça fonctionne, je peux écouter la
musique en ligne directement.

si qqn a une idée pour parer à ceci, je la remercie d'avance!

3 réponses

pegase31 Messages postés 6138 Date d'inscription dimanche 21 décembre 2003 Statut Modérateur Dernière intervention 4 septembre 2013 11
25 janv. 2005 à 05:25
Alors si j'ai bien compris et avec un peu de réflexion, je pense que tu utilises la commande "getUrl" pour jouer ton MP3 alors qu'il faut utiliser la commande "LoadSound".

Si ce n'est pas le cas, n'hésite pas à nous donner la commande qu'il y a sur ton bouton play, et qui déclencherais ce bug ..

Peg'
0
cs_jumpin Messages postés 13 Date d'inscription mercredi 19 mai 2004 Statut Membre Dernière intervention 6 juin 2006
25 janv. 2005 à 08:48
alors voilà la commande qu il y a sur le bouton play:

on(release){
monSon.stop();
monSon = new Sound();
monSon.loadSound(_root.sel,true);
}

...
0
cs_jumpin Messages postés 13 Date d'inscription mercredi 19 mai 2004 Statut Membre Dernière intervention 6 juin 2006
27 janv. 2005 à 09:13
bon en fait après quelques investigations... le problème ne vient pas
du code, mais il semblerait qu'il vienne d'un programme pour accélerer
le download. en effet ce problème se passe chez une personne qui a un
de ces programmes sur son ordi. autrement ça a l'air de fonctionner
parfaitement.



merci Peg' pour t'être penché sur le problème!
0
Rejoignez-nous