Provider jet.oledb.3.51

Signaler
Messages postés
110
Date d'inscription
jeudi 9 mai 2002
Statut
Membre
Dernière intervention
11 mars 2010
-
Messages postés
11
Date d'inscription
lundi 28 octobre 2002
Statut
Membre
Dernière intervention
6 février 2004
-
Allo... Voici un petit bout de mon code...

Private Cat As New ADOX.Catalog
Private Tbl As New ADOX.Table

Public Function CreateDB(link As String) As Boolean

On Error GoTo Annulation
Cat.Create "provider=microsoft.jet.oledb.3.51;" & "Data source =" & link & ";"

With Tbl
.name = "Project"
.Columns.append "Log Nb", adChar, 50
.Columns.append "Sample Nb", adChar, 50
.Columns.append "Name", adChar, 50
.Columns.append "Path", adChar, 255
.Columns.append "Images From", adChar, 255

End With

Cat.Tables.append Tbl
Set Tbl = Nothing

......

Ceci permet de créer une BD!

Mon probleme est lorsque j'arrive pour la compresser avec JRO.Pour y parvenir, je dois ouvrir ma base de donné a l'aide d'un objet JRO.Engine... si j'arrive pour ré-ouvrir ma BD, ca plante... pour y remédier, je dois ouvrir le tout avec .oledb.4.0!!!

Mais si ce change ca dans le petit bout de code qui crée ma BD, c'est maintenant cette partie la qui plante...

Est-ce que quelqu'un a une idée???

Merci

P.S. Je ne peux pas m'amuser a créer ma BD en 3.51 et la lire en 4.0 car ca plante aussi. Ma BD devient illisible tant par VB que par ACCESS.

1 réponse

Messages postés
11
Date d'inscription
lundi 28 octobre 2002
Statut
Membre
Dernière intervention
6 février 2004

Bonjour,
As-tu trouver une solution pour résoudre ce problème ?
Si oui peux tu me dire comment faire car je rencontre le même problème et je ne c'est vraiment pas comment le résoudre.

Pitivier
0