Guestbook flash php

Résolu
barbaralille Messages postés 38 Date d'inscription lundi 3 mai 2004 Statut Membre Dernière intervention 29 décembre 2010 - 15 janv. 2005 à 09:16
Mota2 Messages postés 7 Date d'inscription mercredi 9 juillet 2008 Statut Membre Dernière intervention 9 avril 2010 - 6 mai 2009 à 16:57
bonjour,

j'ai une probleme a propros d'un guestbook en flash !
( ca fait 2 mois que je suis dessus .....)

mon probleme doit venir de mon load movie car mon
guestbook est dans un swf independant !
et je ne recupere pas les donnees envoyées

alors que quand je teste le swf seul ( avec une page html ) cela fonctionne tres bien

je met a disposition mes fichiers sources pour ceux qui veulent jeter un coup d'oeuil et m'aider !
je pense vraiment que cela ne doit pas etre tres compliqué mais je ne m'en sors pas !

avec load movie
http://teurtlebis.free.fr/

html seul ( qui fonctionne !)
http://teurtlebis.free.fr/guestbook.html

sources ( flas / php ....)
http://teurtlebis.free.fr/guestbook-php.rar

Merci d'avance !

Barbara
une debutante en flash
( N'oublier pas que l'on a tous debuté un jour ! )
A voir également:

2 réponses

cs_adv Messages postés 149 Date d'inscription vendredi 30 mai 2003 Statut Membre Dernière intervention 28 janvier 2011 2
15 janv. 2005 à 11:21
Hello,
j'ai fait le tour de ton code, plusieurs choses sont problematiques.
Lorsque l'on code en flash des anims qui vont être intégrées à d'autres animations, il faut faire attention à manière avec laquel on accede au objet.
Deux problèmes se trouvent dans ton code et le load movie n'y est pas directement inclu.
Le premier se trouve sur les instructions "loadVariablesNum". En l'utilisant ainsi, les variables sont retournées par php au niveau 0. Ce qui fait que l'anim seul fonctionne, mais lorsque qu'elle est chargée par une autre, le niveau n'est plus le même. Je les ai remplacée par un loadVariables ("GuestBook.php?NumLow="+NumLow+"&NumHigh="+NumHigh+"&R="+random(999), this); ainsi tout se passe bien. Attention, il y en a plusieurs.
Le deuxième problème se trouve dans le symbol EnterData. Dans le code du bouton, lors de l'envois, tu mets à jour le text status. Pour y acceder, il ne faut pas utiliser _root, car le _root n'est plus le même lorsque l'anim est chargée par une autre. Il faut utiliser _parent, qui accede au parent de l'objet et rend l'anim chargeable par une autre en gardant ces fonctionnalités. Après ça, tout devrait bien fonctionner.
J'espère que ça t'aidera et que tout est compréhensible.
A plus, adv
3
Mota2 Messages postés 7 Date d'inscription mercredi 9 juillet 2008 Statut Membre Dernière intervention 9 avril 2010
6 mai 2009 à 16:57
Salut !!

YESSSsss !!!!

Suite à cette réponse, me voilà soulagé !!!
J'ai enfin réussi grâce à toi, à finir ce maudit site !!!
Merci encore

A++
0
Rejoignez-nous