System.IO

Signaler
Messages postés
5
Date d'inscription
vendredi 5 septembre 2003
Statut
Membre
Dernière intervention
28 janvier 2008
-
Messages postés
7
Date d'inscription
dimanche 20 novembre 2005
Statut
Membre
Dernière intervention
29 décembre 2005
-
Avis aux experts!

Sur ma bécanne A (W2K), j'instancie mon composant FileSystemWatcher et ça marche, mais sur ma bécanne B (XP), ça ne marche pas, et l'on me répond:

'An unhandled exception of type 'System.Security.SecurityException' occurred in Unknown Module'

Ci-dessous, le code incriminé:
******************************
Imports System
Imports System.IO

Public Class Watcher

Public Shared Sub Main()

' OUVRE UN NVO FileSystemWatcher
Dim watcher As New FileSystemWatcher
watcher.Path = "D:"

End Sub

End Class

******************************

QQ aurait-il une idée??? 'doit y avoir un truc au nivo de l'Assembly, mais lequel?

5 réponses

Messages postés
2336
Date d'inscription
samedi 14 juillet 2001
Statut
Membre
Dernière intervention
5 mai 2009
4
c est un problème de sécurité tout simplement
faudrais savoir la ligne exact de l'erreur et son numéro
ensuite prend le numéro et fais une recherche sur google, tu trouve 9 fois sur 10 la réponse
-------------------------------------------------
Dragon alias aussi Waxime mais bon, pas le gout de refaire un nouveau profil lol
-------------------------------------------------
Messages postés
5
Date d'inscription
vendredi 5 septembre 2003
Statut
Membre
Dernière intervention
28 janvier 2008

'sur ke tu va trouver:

Merci, mais c 1 petit peu justement ce ki me koz des soucis...

Je sais exactement là où il y a 1 erreur, c qd je fais
Dim toto as new FileSystemWatcher

en fait, mm en step by step, il en veut pas, dans le log g ceci:

The granted set of the failing assembly was:
















***
VOIR PLUS HAUIT POUR LE PRB INITIAL
merci d'avance!!!
Messages postés
6063
Date d'inscription
dimanche 13 avril 2003
Statut
Modérateur
Dernière intervention
15 juillet 2011
26
salut

http://groups.google.com/...

d'apres ce post c'est le sp1 de xp qui veut pas
est ce sur la meme machine

evite de mettre des lettres en dur dans le code
il y a surement une struture dans system.io
qui te donnera la liste des disques et compagnie(type amov cd reseau ...) --> plus de securité

esperant d'avoir guider un peu

voila
Messages postés
5
Date d'inscription
vendredi 5 septembre 2003
Statut
Membre
Dernière intervention
28 janvier 2008

Bon, j'ai finallement trouvé une solution autour de la sécurité:
****************************************
Voilà, il faut ouvrir ça:
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\mscorcfg.msc

Dans l'arborescence, il faut ouvrir:
- Runtime Security Policy
- Enterprise
- Code groups
- All_Code : clic-droit + Properties

...dans l'omglet [Permission Set], mettre FullTrust

****************************************

Si ça peut aider qq...
Messages postés
7
Date d'inscription
dimanche 20 novembre 2005
Statut
Membre
Dernière intervention
29 décembre 2005

merci pour la solution, car moi aussi j'ai le meme probleme