Aide urgent sur rs232 + hpe3631a

Signaler
Messages postés
2
Date d'inscription
mardi 18 juin 2002
Statut
Membre
Dernière intervention
21 juin 2002
-
Messages postés
2
Date d'inscription
mercredi 4 mai 2005
Statut
Membre
Dernière intervention
15 mai 2005
-
Salut a tous, g un pb car je doit gerer une alim par liaison distance rs232.
Mon problem est que quand j'envoit une commande a l'alim, elle ne la comprend pas:
J'ouvre le com1, je le charge de "SYST:REM" et la machine la recoit mais ne la comprend pas alors que cette commande est belle et bien celle qu'elle doit recevoir.
Peut etre que je doit charger le com un d'un tableau qui envoit lettre par lettre mais je ne sait pas fair ca sous vb car je viens juste de le decouvrir
est ce que quelqu'un peut me donner des exemple de programme qui pourrait m'interresser

3 réponses

Messages postés
386
Date d'inscription
samedi 4 octobre 2008
Statut
Membre
Dernière intervention
19 février 2018
2
Bonjour,

Ton prob est tous béte a résoudre, ton com (Dll) est mal configurer. De base quand tu prend le composant celui-ci est presque null.

Je peut t'envoyer un prog qui recherche les modems et dialogue aussi avec celui-ci en Hayes (At).

Donc donne moi ton e-mail et je fais cela ce soir.

[Gally Home Corp]
0
Messages postés
2
Date d'inscription
mardi 18 juin 2002
Statut
Membre
Dernière intervention
21 juin 2002

Merci beaucoup de ton aide. Par contre, j'ai trouvé mon probleme.
La machine recevait bien ce que je lui envoyé par contre elle ne l'executé pas:dans la doc de 2000000 page, il y a 1 ligne qui dit qu'il faut mettre le caractere "saut de ligne" à la fin de chaque commande.
G donc mis une fonction saut de ligne en debut de prog et je la rappel apres chaque commande.
Merci beaucoup en tout cas.
0
Messages postés
2
Date d'inscription
mercredi 4 mai 2005
Statut
Membre
Dernière intervention
15 mai 2005

Salu
je doi oci commander à distance un générateur AOIP (je me demande meme si ta commande SYTM REM n'est pas aussi de AOIP) via rs232. Qd jlui demande de généré 2V par le composant mscomm, il reste sur 0V.
Pouré tu menvoyé ce qu'on ta doné et ce que tu a déjé fé à l'adresse [mailto:janse2@esstin.uhp-nancy.fr janse2@esstin.uhp-nancy.fr], ca seré sympa et pouré suremen maidé à mieu comprendre (jsui novice en vb,).
merci d'avance
0