Votre max_execution_time

Signaler
Messages postés
60
Date d'inscription
lundi 6 octobre 2003
Statut
Membre
Dernière intervention
18 août 2006
-
Messages postés
60
Date d'inscription
lundi 6 octobre 2003
Statut
Membre
Dernière intervention
18 août 2006
-
Il se trouve que certaines de mes pages génèrent du pdf à partir de requêtes mySQL. Et il arrive que ces scripts prennent une éternité lorsque beaucoup d'enregistrements sont retournés et m'affiche l'erreur de dépassement de la durée max d'exécution.

Je me doute qu'augmenter la durée d'exécution donnerais plus de temps à un individu mal intentionné pour faire ce qu'il veut mais est-ce vraiment critique de mettre 1 minutes voire 2 ? Dans le php.ini, ca donnerait donc ca : max_execution_time = 120

Merci d'avance.
Bonne journée.
A voir également:

2 réponses

Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
9
Salut :-)

La plupart des hébergements en mutualisé n'acceptent pas plus de 30 secondes d'éxécution (je connais un hébergeur qui limite même à 7 secondes, mais bon il est à fuir, consulte bien le phpinfo des hébergeurs que tu visites). Donc en local tu peux même mettre un temps d'éxécution illimité, mais attention aux boucles infinies...

Donc si tu es en dédié pas de problème mais en mutualisé aucun hébergeur ne laisse la possibilité de configurer cette option à ma connaissance.

A ++

http://www.vulgarisation-informatique.com : entraide, dépannage et vulgarisation informatique
Messages postés
60
Date d'inscription
lundi 6 octobre 2003
Statut
Membre
Dernière intervention
18 août 2006

Merci a+