HyperLinkColumn - problème

cs_eihpos Messages postés 22 Date d'inscription vendredi 1 mars 2002 Statut Membre Dernière intervention 4 février 2005 - 28 oct. 2004 à 10:50
cs_eihpos Messages postés 22 Date d'inscription vendredi 1 mars 2002 Statut Membre Dernière intervention 4 février 2005 - 2 nov. 2004 à 16:30
Bonjour à tous,
J'ai un soucis avec une Datagrid. J'initialise les colonnes de la façon suivnte :

DGUtil.AutoGenerateColumns = False
'Nom
l_o_Hcol = New HyperLinkColumn
l_o_Hcol.HeaderText = "Nom"
l_o_Hcol.DataNavigateUrlField = "Nom"
l_o_Hcol.DataNavigateUrlFormatString = "SrcSia.aspx?mode={0}"
DGUtil.Columns.Add(l_o_Hcol)
'Prénom
l_o_col = New BoundColumn
l_o_col.HeaderText = "Prénom"
l_o_col.DataField = "Prenom"
l_o_col.SortExpression = l_o_col.DataField
DGUtil.Columns.Add(l_o_col)
'Code SIA
l_o_col = New BoundColumn
l_o_col.HeaderText = "SIA"
l_o_col.DataField = "SIA"
l_o_col.SortExpression = l_o_col.DataField
DGUtil.Columns.Add(l_o_col)

Ensuite je lui colle le dataset :

DGUtil.DataSource = p_o_ds
DGUtil.DataBind()

Pour les Boundcolumns pas de pb mais pour la colonne hyperlink il me répond la chose suivante :

L'argument spécifié n'était pas dans les limites de la plage des valeurs valides. Nom du paramètre : index

Ca fait un bon moment que je cherche quelle c... j'ai pu faire mais je n'y arrive pas !!!

Alors si vous pouvez m'éclairer de vos lumière, ce serait super sympa.

Merci

SoPhIe
:blush)
A voir également:

1 réponse

cs_eihpos Messages postés 22 Date d'inscription vendredi 1 mars 2002 Statut Membre Dernière intervention 4 février 2005
2 nov. 2004 à 16:30
Personne ne peut m'aider ?
S'il vous plait un bo geste !!!

Merci
%-6
0