Probleme avec fonction dans OnSubmit

Signaler
Messages postés
202
Date d'inscription
jeudi 24 juin 2004
Statut
Membre
Dernière intervention
22 janvier 2009
-
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
-
Hello tout le monde,
J'ai un petit probleme que je n'arrive pas a resoudre. J'ai un formulaire et je veux qu'une série de test soit effectué pour vérifier la conformité des infos. Donc j'ai tapé :
<FORM Name="formulaire" method="post" action="mapage.asp" OnSubmit="return verifierFormulaire()">

La fonction verifierFormulaire() retourne True si c'est bon, et vous vous en douterez, False si c'est pas bon. Mais le problème dans tout ca, c'est que la fonction n'est jamais exécuter quand je valide. Pour en etre sur, j'ai foutu un alert("Coucou"); dans à l'entrée de ma fonction mais il ne s'affiche jamais. La fonction en elle meme est déclarée entre les balises <HEAD>

Alors quelqu'un peut-il m'expliquer svp ? Car la, je pete un plomb quand je vois que je fais exactement la meme chose sur une autre page est que ca marche nickel... Ca me depasse ! Pliiiizzzzzeeeeeeee

Merci d'avance. A plus

3 réponses

Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
36
Bonjour,
ch'tit exemple qui retourne
la réponse à un confirm
<HTML>
<HEAD>
<TITLE></TITLE>
<script type="text/javascript">
function verifierFormulaire()
{ return confirm("texte",""); }
</script>
</HEAD>

<FORM Name="formulaire" method="post" 
action="mapage.asp" 
OnSubmit="return (verifierFormulaire());">

</form>
</HTML>

plusieurs pistes :
_ pas de bouton submit
_ pas de </form>
_ mauvaise ortografe du nom de fonction
_ pas de </script>
_ " ou ' manquant ...
ou que sais-je encore ???
Cordialement Bul. [Site] [[mailto:marcel.Bultez@Tiscali.fr Mail]]
Messages postés
202
Date d'inscription
jeudi 24 juin 2004
Statut
Membre
Dernière intervention
22 janvier 2009
1
Franchement, j'ai tout regardé !!!! Les quote ou double-quote, l'orthogarphe... franchement, je trouve pas ! MEme en faisant un copier coller d'une autre page ou ca fonctionne... il veut rien savoir. J'ai opter alors pour un autre solution plus radicale. ASP et un history.back si c'est pas bon ! Mais ptain que c'est chiant ! lol
Merci quand meme de ton aide*
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
36
c'est vrai que la syntaxe et les détections/messages
d'erreurs ne sont pas géniaux/géniaux.
un petit bout de code nous aiderait ...
Cordialement Bul. [Site] [[mailto:marcel.Bultez@Tiscali.fr Mail]]