Exécuter un .jar, could not find main class

Résolu
indo__
Messages postés
29
Date d'inscription
mardi 8 juin 2004
Statut
Membre
Dernière intervention
4 février 2006
- 13 sept. 2004 à 14:20
indo__
Messages postés
29
Date d'inscription
mardi 8 juin 2004
Statut
Membre
Dernière intervention
4 février 2006
- 15 sept. 2004 à 01:52
Boujour, voila je rencontre un pb quand j'execute un .jar, je recoi un message d'erreur "could not find main class". G deja cherché dans le forum je n'ai rien trouvé, est ce que ququ1 aurait une ID, sachantque j'utilise l'API de JavaMail, faut-il intégrer les fichiers de cette dernière, et comment si c le cas, merci d'avance

10 réponses

indo__
Messages postés
29
Date d'inscription
mardi 8 juin 2004
Statut
Membre
Dernière intervention
4 février 2006

15 sept. 2004 à 01:52
A force de chercher, j'ai enfin trouvé pkoi le .jar ne voulait po se lancer, en fait g ouvert le .jar avec winrar et g intégré les classes de l'api javamail en respectant la structure, et voila a mache :) je remercie ttes les personnes qui mon accordé du tmp pour m'aider, je vous souhaite bonne continuation
3
asx9
Messages postés
64
Date d'inscription
dimanche 19 octobre 2003
Statut
Membre
Dernière intervention
18 novembre 2004
1
13 sept. 2004 à 16:28
asx9

peux tu préciser ton pb.
tu appelles des méthodes de ton jar à partir d'une servlet ?
0
indo__
Messages postés
29
Date d'inscription
mardi 8 juin 2004
Statut
Membre
Dernière intervention
4 février 2006

13 sept. 2004 à 21:19
Hum, alors voila g recup un code qui utilise l'api JavaMail, le code fonctionne tres bien dans l'IDE (Eclipse), mais quand je ve l'exporte en .jar, il m'affiche le message "could not find main class" je me demande si sa vient po d'un CLASSPATH à mettre dans les variables d'environement de l'OS :(
0
indo__
Messages postés
29
Date d'inscription
mardi 8 juin 2004
Statut
Membre
Dernière intervention
4 février 2006

13 sept. 2004 à 21:21
je precise c a l'execution du .jar que j'ai le message d'erreur, merci d'avance
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
asx9
Messages postés
64
Date d'inscription
dimanche 19 octobre 2003
Statut
Membre
Dernière intervention
18 novembre 2004
1
14 sept. 2004 à 09:44
quand tu as fais ton .jar tu y as bien mis toutes les classes dont tu avais besoin ?
0
indo__
Messages postés
29
Date d'inscription
mardi 8 juin 2004
Statut
Membre
Dernière intervention
4 février 2006

14 sept. 2004 à 13:23
Vi, enfin je pense, je laisse faire Eclipse pour ca. Dans mon projet sous l'ide je mets bien toutes les classes et ca passe sans pb, mais apres quand j'exporte mon .jar et que je l'execute a mache po :( peut etre que je n'ai po inclu les classes necessaires, mais comment faire si c le cas.
0
asx9
Messages postés
64
Date d'inscription
dimanche 19 octobre 2003
Statut
Membre
Dernière intervention
18 novembre 2004
1
14 sept. 2004 à 14:10
tu l'exécutes où ton jar, dans tomcat ?
si ton programme n'est pas une servlet ou une applet tu dois avoir une méthode main ( ).
tu dois configurer d'une certaine manière ton "run" dans eclipse qui n'est pas accepté hors eclipse........
0
indo__
Messages postés
29
Date d'inscription
mardi 8 juin 2004
Statut
Membre
Dernière intervention
4 février 2006

14 sept. 2004 à 17:31
Dans les options run de eclipse il me semble que tout est configuré correctement, en tt K les .jar de l'api Javamail y sont. Quand je lance mon .jar en console msdos (java -jar monfichier.jar) je reçois ce message d'erreur "Exception in thread "main" java.lang.NoClassDefFoundError: javax/mail/MessagingException". Merci pour vos réponses ;)
0
asx9
Messages postés
64
Date d'inscription
dimanche 19 octobre 2003
Statut
Membre
Dernière intervention
18 novembre 2004
1
14 sept. 2004 à 17:51
pour envoyer un mail il faut configurer le smtp en nommant celui de ton fournisseur d'accès (ex: smtp.wanadoo.fr). mais il faut un serveur d'application pour faire cette config.

tu arrive à envoyer un mail avec ton appli à partir d'eclipse ou tu le compile seulement sans message d'erreur ?
0
indo__
Messages postés
29
Date d'inscription
mardi 8 juin 2004
Statut
Membre
Dernière intervention
4 février 2006

14 sept. 2004 à 19:02
pour le moment l'appli ne permet que de recupérer les mail, mais j'arrive a les recuperer sans pb sous eclipse bien sur, pake en .jar g le message d'erreur, donc je pense que sa vient du fait quil ne trouve po les libs, certainement un pb au niveau du CLASSPATH, dans le fichier manifest ? ou au nivo de l'OS ? :)
0