Erreur 91 Variable objet non defini "avec WebBrowser"

Résolu
cs_clementpat
Messages postés
406
Date d'inscription
lundi 2 décembre 2002
Statut
Membre
Dernière intervention
25 janvier 2014
- 11 sept. 2004 à 12:17
cs_clementpat
Messages postés
406
Date d'inscription
lundi 2 décembre 2002
Statut
Membre
Dernière intervention
25 janvier 2014
- 12 sept. 2004 à 20:43
bonjour a tous .

quand je fait fonctionner ce programme en le testant directement dans VB y a pas d'erreur , mais si je creer l'EXE et que je demarre ce programme par celui-ci , le programme ne fonctionne pas et il me sort " erreur 91 Variable objet non defini " je sait que l'erreur vient de la section webBrowser :

Private Sub Command1_Click()
Code.Text = vbNullString
Label1 = "chargement de la page dans le webbrowser"
WebBrowser1.Navigate TxtUrl
End Sub

Private Sub Form_Load()
WebBrowser1.Navigate ""
End Sub

Private Sub WebBrowser1_DownloadComplete()
CodeSrc = WebBrowser1.Document.documentElement.innerHTML
'recupération du codesrc
Code.Text = CodeSrc
Label1 = vbNullString
End Sub

j'est tester sur xp et mille
est sur 2 pc differents
le probleme se pausse seulement en demarrant par le EXE
j'ai pris le code a cette adresse :

http://www.vbfrance.com/code.aspx?ID=19289

comment faire pour resoudre ce probléme !
merci ceux qui peuvent m'eclairer
Amicalement/
A voir également:

3 réponses

cs_clementpat
Messages postés
406
Date d'inscription
lundi 2 décembre 2002
Statut
Membre
Dernière intervention
25 janvier 2014

12 sept. 2004 à 20:43
c'est bon j'ai resolut le probléme en ajoutant :
On Error Resume Next

Private Sub WebBrowser1_DownloadComplete()
On Error Resume Next

CodeSrc = WebBrowser1.Document.documentElement.innerHTML
'recupération du codesrc
Code.Text = CodeSrc
Label1 = vbNullString
End Sub

Merci .
patrick
3
crenaud76
Messages postés
4172
Date d'inscription
mercredi 30 juillet 2003
Statut
Membre
Dernière intervention
9 juin 2006
28
11 sept. 2004 à 21:58
Déplace la ligne de code de l'EVT Form_Load vers l'EVT Activate !
Cela passera peut-être mieux !

Christophe R.
0
cs_clementpat
Messages postés
406
Date d'inscription
lundi 2 décembre 2002
Statut
Membre
Dernière intervention
25 janvier 2014

12 sept. 2004 à 16:17
merci pour ta reponse , je viens d'essayer , mais cela ne resoud pas le probléme .
patrick
0