ERREUR SESSION

Signaler
Messages postés
31
Date d'inscription
mardi 17 août 2004
Statut
Membre
Dernière intervention
17 janvier 2005
-
Messages postés
185
Date d'inscription
samedi 21 mai 2005
Statut
Membre
Dernière intervention
16 juillet 2016
-
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/63/g/g/e/ggehector.com/www/images_news/index.php:2) in frames_page500.php on line 10

Qui peux mexpliquer cette erreur qui ce trouve sur une page d'une zone membre de mon site ??

merci d avance :)

6 réponses

Messages postés
53
Date d'inscription
samedi 7 décembre 2002
Statut
Membre
Dernière intervention
7 août 2007

Salut,

je pense que l'erreur vient du fait que la commande session_start() n'est pas au tout début de ta page (elle se trouve à la ligne 10). Il faut absolument qu'elle soit envoyée en premier, avant tout autre chose.

Voila, j'espère avoir résolu ton pb.

avec PouPou, rien n'est impossible
Messages postés
31
Date d'inscription
mardi 17 août 2004
Statut
Membre
Dernière intervention
17 janvier 2005

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/63/g/g/e/ggehector.com/www/images_news/index.php:2) in frames_page500.php on line 1

Tjs la meme chose :-(
Messages postés
60
Date d'inscription
mercredi 9 juillet 2003
Statut
Membre
Dernière intervention
3 septembre 2004

Salut,

Il faut pas non plus que ta page soit inclut dans une autre, sinon affiche ton script sa sera plus facile à debeuger.

Une bonne programmation c'est avant tout une bonne analyse. :)
Messages postés
31
Date d'inscription
mardi 17 août 2004
Statut
Membre
Dernière intervention
17 janvier 2005

Ben d apres moi c'est ca le probleme ... j ai une page index qui inclu les differentes pages de mon site et une des pages inclus une autre ... comment faire alors ? sachant que les 2 doivents absolument inclure une autre !!
Messages postés
31
Date d'inscription
mardi 17 août 2004
Statut
Membre
Dernière intervention
17 janvier 2005

Personne pour maider ??
Messages postés
185
Date d'inscription
samedi 21 mai 2005
Statut
Membre
Dernière intervention
16 juillet 2016

ben, en fait, moi j'ai eu le problème,

et au bout d'un quart d'heure de recherche sur le site, je me suis rendu compte que ça devait être un truc tout simple, et c'était le cas :
il y avait un espace entre le debut du fichier index.php et la balise ' <?php'

j'ai donc mis '<?php session_start(); .....?>' au lieu de ' <?php session_start(); .....?>'

je précise que je débute en php, mais bon, voilà le truc qui énerve, c'est vraiment du genre faux contact en électronique, tu passe une heure à chercher la solution et puis,
bon tu te sens un peu bête quand t'as trouvé,

et puis c'est pas mis sur le site, alors que je pense que ça a du arriver à plusieurs au début :o)