Email Format Mime Entete instable.

Signaler
Messages postés
163
Date d'inscription
lundi 29 septembre 2003
Statut
Membre
Dernière intervention
8 mai 2010
-
Messages postés
296
Date d'inscription
mercredi 10 septembre 2003
Statut
Membre
Dernière intervention
11 septembre 2004
-
Antidote ;)

Salut à tous, je viens poser une question légèrement hors php mais je cherche véritablement la source de mon problème.

Depuis quelques temps mon envoie d'email format HTML (multipart) ne foctionne plus. La raison l'entête. Selon l'entête ça passe ou ça casse.

voici celui de base : (je ne met pas la décoration php sinon on ne sans sort pas, je met juste la partie qui rentre dans l'entete. $u étant set avec un iniquid() )

Return-Path: $rp
From: $from
Sender: $from
Reply-to: $rp
Cc: $cc
Bcc: $bcc
Organization: Test
Message_ID: $l@mailer.test
Date: ".date("D, j M Y H:i:s -0600")."
X-Sender: $from
X-Priority: 3
X_Mailer : Test
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_$u"

Bon alors ça , ça passait mais ça ne passe plus. Voiçi d'autre exemple.

ceci passe :

MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_$u"

ceci passe :

Date: ".date("D, j M Y H:i:s -0600")."
X-Sender: $from
X-Priority: 3
X_Mailer : Seza
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_$u"

ceci passe :

From: $from
Reply-to: $rp
Cc: $cc
Bcc: $bcc

ceci ne passe pas

From: $from
Reply-to: $rp
Cc: $cc
Bcc: $bcc
Date: ".date("D, j M Y H:i:s -0600")."

ceci ne passe pas

From: $from
Cc: $cc
Bcc: $bcc
X-Sender: $from
X-Priority: 3
X_Mailer : Seza

ceci ne passe pas : >_<

[blue]From: $from
Cc: $cc
Bcc: $bcc
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_$u"

Voyez le topo... Bon config système :

PHP 4.3.8
Postfix 2.1.4
SpamAssassin 2.64

Si vous trouver.... Et bien chapeau bas.

4 réponses

Messages postés
163
Date d'inscription
lundi 29 septembre 2003
Statut
Membre
Dernière intervention
8 mai 2010

Antidote ;)

Désolé j'ai foiré les codes couleurs le bouton pour le code ne fais rien :s
Messages postés
296
Date d'inscription
mercredi 10 septembre 2003
Statut
Membre
Dernière intervention
11 septembre 2004

T'inquiet les balise bug facilement ici.

Pourquoi tu veux envoyer autants d'information?

en php il y a la fonction mail de très bien expliqué dans php.net.

en perl je l'ai déjà fait pour envoyer des mail à partir d'un autre serveur, si tu veux le code...

FlashFun 8-) [mailto:toujours_zen@hotmail.com :question) ]
Messages postés
163
Date d'inscription
lundi 29 septembre 2003
Statut
Membre
Dernière intervention
8 mai 2010

Antidote ;)

J'utilise la fonction mail php .. Pour le mail que je veux passer il me faut au minim dans l'entete

From :
Reply-to :
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_$u\

Pour pouvoir envoie mon mail en text/html. Ça a toujours marché depuis près de deux an sur mes anciens serveur là ça bug je cherche pourquoi.
Messages postés
296
Date d'inscription
mercredi 10 septembre 2003
Statut
Membre
Dernière intervention
11 septembre 2004

Ok, mais on peut pas t'aider.

Le problème vient peut-être du programme ou d'ailleurs...

Moi, je ne vois pas comment t'aider. dsl

FlashFun 8-) [mailto:toujours_zen@hotmail.com :question) ]