Pb Erreur automation -2147221231 [Résolu]

Signaler
Messages postés
8
Date d'inscription
vendredi 13 août 2004
Statut
Membre
Dernière intervention
19 août 2004
-
Messages postés
8
Date d'inscription
vendredi 13 août 2004
Statut
Membre
Dernière intervention
19 août 2004
-
Bonjour à tous.

J'ai un pb sur le pilotage de MS Word depuis une application VB 6.
Cette erreur n'est pas systèmatiquement présente sur tous les postes installés.
Au moment de la création d'un objet Word.Application ou de la récupération d'un objet existant, l'erreur -2147221231 : Erreur Automation se produit. Son libellé exact est : "Class Factory ne peut fournir la classe demandée".

Après recherche sur différents forums, je constate que je ne suis pas le seul à avoir ce pb. Beaucoup n'ont pas de solution.
Sur un cas solutionné, il y avait blocage entre Norton Antivirus 2000 et Office 2000.

SVP, aidez-moi...

3 réponses

Messages postés
2169
Date d'inscription
vendredi 20 avril 2001
Statut
Membre
Dernière intervention
30 juin 2009
8
tu peux essyer de contacter Titatou..il avait le meme souci que toi :
http://www.vbfrance.com/forum.v2.aspx?ID=222183

It@li@
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 123 internautes nous ont dit merci ce mois-ci

Messages postés
437
Date d'inscription
mercredi 18 décembre 2002
Statut
Membre
Dernière intervention
10 août 2010
1
Je confirme le problème. Je l'ai personnellement rencontré et les seules solutions envisageables à l'époque étaient :

- changer l'antivirus (inconcevable pour la plupart des entreprises).
- utiliser autre chose que Word 2000 (ça marche avec Word 97, XP, 2003, ...).
- désactiver la prise en charge des documents Ms Office au niveau de Norton Antivirus.
- passer par des GetObject, mais cela implique de faire ouvrir manuellement Ms Word à l'utilisateur (on peut aussi aller en base de registrer pour lire l'instruction à lancer pour démarrer Word avec un document neuf)
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 123 internautes nous ont dit merci ce mois-ci

Messages postés
8
Date d'inscription
vendredi 13 août 2004
Statut
Membre
Dernière intervention
19 août 2004
1
C'est résolu. Il s'agit bien d'un conflit entre des applications. MS Office, Norton ou mon application, je n'en sais rien.

La réinstallation de mon application a résolu le pb.

Merci à tous. :)