Variable Session() reste vide

Signaler
Messages postés
1
Date d'inscription
vendredi 11 avril 2003
Statut
Membre
Dernière intervention
10 août 2004
-
Messages postés
1
Date d'inscription
jeudi 21 août 2003
Statut
Membre
Dernière intervention
14 octobre 2004
-
Bonjour,

J'ai crée une appli qui crée une variable Session("util") au moment du login utilisateur.

Tout marchait bien sur mon poste (Win2000 / IIS) donc je l'ai installée sur le serveur Web (Win 2000 serveur / IIS)

Quand j'accède à l'appli à distance et me log, la variable Session("util") reste vide.

Par contre, quand j'y accède à partir d'autres postes, il n' y a aucun problème. Le problème vient donc de mon poste, mais cela marchait en local.
.... Je suis donc un peu perdu !

Merci d'avance pour votre aide

2 réponses

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
27
tout foncionne bien sur les autres postes ? meme si tu te deconnectes et reconnecte ?
Essaye de vider les cookies, c'est possible que ca vient de la, ca me semblerait louche, mais c'est pas impossible.

Si ca marche toujours pas, je ne vois aucune raison, tu es sur que ca marche correctement sur les autres postes ?

Cyril
Messages postés
1
Date d'inscription
jeudi 21 août 2003
Statut
Membre
Dernière intervention
14 octobre 2004

Salut,

J'ai vécu une situation similaire. Dans mon cas, l'erreur était causée par le fait que le poste de travail bloquait les "Cookies" au niveau de la sécurité internet. Étant donné que la variable Session() semble s'inscrire dans un "Cookie" celle-ci restait vide d'un appel à l'autre de la page ASP.

Ma solution a été simplement de permettre l'usage des "Cookies" sur le poste de travail.

Bonne chance !