Pb avec dev-c : unable to run program files

Messages postés
15
Date d'inscription
vendredi 30 juillet 2004
Statut
Membre
Dernière intervention
14 septembre 2004
-
Messages postés
6535
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
22 août 2010
-
Voilà je débute et des que je lance un fichier.c il me met cela et ne compile pas???

j'ailmerais résoudre ce pb,
MERCI

10 réponses

Messages postés
6535
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
22 août 2010
10
Tu as installé le compilateur avec? Essaie directement en ligne de commande gcc fichier.c
Messages postés
15
Date d'inscription
vendredi 30 juillet 2004
Statut
Membre
Dernière intervention
14 septembre 2004

mais quel compilateur???
il comppile pas dejà dev-c???
et sinon le compilateur je le trouve dans les package??mais c'est koi son pti nom??

gcc.???
je suis sous windows..

merci à vous!!
Messages postés
6535
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
22 août 2010
10
MinGW version Windows de gcc

www.mingw.org
Messages postés
15
Date d'inscription
vendredi 30 juillet 2004
Statut
Membre
Dernière intervention
14 septembre 2004

comprends pas faut que j'installe ceci avec dev-c++

je croyais qu'il compilait...comme un garnd

je viens de passer de la 4... a la derniere et la ca marcherais plus???

bon le point positif c'est qu'elle est belle et en french...
Messages postés
6535
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
22 août 2010
10
Dev-C++ est un simple éditeur à la con. Reste a savoir si ti a téléchargé la version avec ou sans compilo. Regarde si tu a un dossier bin, ou recherche gcc.exe
Messages postés
15
Date d'inscription
vendredi 30 juillet 2004
Statut
Membre
Dernière intervention
14 septembre 2004

ok c'est tout maintenant il me pete :
[Linke error] undefined reference to 'SDL_RWFromFile'

et une dizaine de ligne avec 'SDL_LoadBMP_RW'
'SDL_Fill_Rect'

enfin bref toute les fonctions que j'ai appellé...

puis-je te filer mon code ou c'est une erreur dev-c++

il s'agit d'un morpion 10x10 avec interface graphique
Messages postés
6535
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
22 août 2010
10
Tu utilise librairie SDL, donc tu dois ajouter un truc dans les options du linker, du stlye -lsdl (je peux pas dire quoi exactement)
Messages postés
15
Date d'inscription
vendredi 30 juillet 2004
Statut
Membre
Dernière intervention
14 septembre 2004

je suis sou windows...

donc je clic sur le bouton compiler!!!

NON !!!
Messages postés
15
Date d'inscription
vendredi 30 juillet 2004
Statut
Membre
Dernière intervention
14 septembre 2004

en ajoutant dans les options du compilateur -lsdl
ca regle presque tous les pb..

mais en reste un :[Linker error ] undefined reference to 'Winmain@16'

encore un lien a une autre biblio???
merci???
Messages postés
6535
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
22 août 2010
10
Non, la c'est un autre probleme. Dans project type, essaie de mettre Win32 Console au lieu de Win32 GUI