Mode graphique avec dev c++

Signaler
Messages postés
79
Date d'inscription
dimanche 1 juin 2003
Statut
Membre
Dernière intervention
11 mai 2007
-
Messages postés
79
Date d'inscription
dimanche 1 juin 2003
Statut
Membre
Dernière intervention
11 mai 2007
-
salut

Voila, je compile avec Dev C++, et je sais pas comment afficher des images, passer en mode plein écran, mettre la souris etc...

Si qqn peut me dire ou je peux trouver des cours la dessus, ou alors tout simplement me dire comment faire ;-)

Merci

31 réponses

Messages postés
546
Date d'inscription
vendredi 13 février 2004
Statut
Membre
Dernière intervention
9 janvier 2008
1
ET pis t'as quelle version de devcpp?
Messages postés
546
Date d'inscription
vendredi 13 février 2004
Statut
Membre
Dernière intervention
9 janvier 2008
1
Le mieux cce serait qu'on te debugge sur msn messenger alors si t'as une adresse....
Messages postés
1267
Date d'inscription
mercredi 1 janvier 2003
Statut
Membre
Dernière intervention
28 février 2007
3
Qu'on "me" débuggue?
Sur MSN moi c funto66 at hotmail.com...

---------------------------------------------------------
Patience et longueur de temps font plus que force
ni que rage....
Coucous flingueurs 3D : http://www.freewebs.com/cf3d/

Un concours de prog graphique, ça vous dit? c'est sur Coder-Studio : h
Messages postés
79
Date d'inscription
dimanche 1 juin 2003
Statut
Membre
Dernière intervention
11 mai 2007

mani_hak@hotmail.com
Sinon j'ai la version 4.je sais pas quoi lol faites en septembre 2000 ;-)

Donc voilà, vous avez mon adresse now lol je t'ajoute à mes contactes Funto66
Messages postés
546
Date d'inscription
vendredi 13 février 2004
Statut
Membre
Dernière intervention
9 janvier 2008
1
et moi stephane_44@hotmail.com

Et pis c pas toi qui a un probleme funto66 ! C'est sullyper qu'il faut debugger!
Messages postés
1267
Date d'inscription
mercredi 1 janvier 2003
Statut
Membre
Dernière intervention
28 février 2007
3
Ok j'avais mal compris ^^
sullyper >> c'est normal alors, télécharge Dev-C++ 4.9.9.0 et là t'auras un PackMan.exe tout prêt à installer ton joli package :)
Enfin, d'un autre côté, si depuis le début t'avais suivi le tutorial sur OpenGL que j'ai écrit sur AmK-Project t'aurais pas eu tous ces problèmes...enfin moi je dis ça comme ça hein :p

---------------------------------------------------------
Patience et longueur de temps font plus que force
ni que rage....
Coucous flingueurs 3D : http://www.freewebs.com/cf3d/

Un concours de prog graphique, ça vous dit? c'est sur Coder-Studio : h
Messages postés
1267
Date d'inscription
mercredi 1 janvier 2003
Statut
Membre
Dernière intervention
28 février 2007
3
Ok j'avais mal compris ^^
sullyper >> c'est normal alors, télécharge Dev-C++ 4.9.9.0 et là t'auras un PackMan.exe tout prêt à installer ton joli package :)
Enfin, d'un autre côté, si depuis le début t'avais suivi le tutorial sur OpenGL que j'ai écrit sur AmK-Project t'aurais pas eu tous ces problèmes...enfin moi je dis ça comme ça hein :p

---------------------------------------------------------
Patience et longueur de temps font plus que force
ni que rage....
Coucous flingueurs 3D : http://www.freewebs.com/cf3d/

Un concours de prog graphique, ça vous dit? c'est sur Coder-Studio : http://www.coder-studio.com/forums/index.php?showtopic=64
Messages postés
79
Date d'inscription
dimanche 1 juin 2003
Statut
Membre
Dernière intervention
11 mai 2007

OK
En fait je l'avais déjà dl mais quand je l'installe elle bug... je vais la re dl, bon et sinon, du coup j'ai quand même réussi à extraire le pack, je les ai transféré sur l'anciens dev c++, et quand je veux ouvrir un prog genre : "scrolling_bk" pris sur ton site funto, et bah il me sort :

C:\WINDOWS\TEMP\cczbW9fb.o(.text+0xae):code.c: undefined reference to `blit'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x128):code.c: undefined reference to `blit'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x176):code.c: undefined reference to `makecol'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x18d):code.c: undefined reference to `_imp__font'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x19b):code.c: undefined reference to `textout'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x1d0):code.c: undefined reference to `masked_blit'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x1ea):code.c: undefined reference to `_imp__screen'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x1f8):code.c: undefined reference to `blit'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x235):code.c: undefined reference to `install_allegro'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x23d):code.c: undefined reference to `install_keyboard'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x242):code.c: undefined reference to `install_timer'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x24c):code.c: undefined reference to `set_color_depth'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x267):code.c: undefined reference to `set_gfx_mode'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x272):code.c: undefined reference to `_imp__gfx_driver'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x27c):code.c: undefined reference to `_imp__gfx_driver'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x28b):code.c: undefined reference to `_imp__gfx_driver'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x295):code.c: undefined reference to `_imp__gfx_driver'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x2a4):code.c: undefined reference to `create_bitmap'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x2bd):code.c: undefined reference to `load_bitmap'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x2d4):code.c: undefined reference to `load_bitmap'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x2e1):code.c: undefined reference to `_imp__key'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x2f1):code.c: undefined reference to `_imp__key'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x303):code.c: undefined reference to `_imp__key'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x316):code.c: undefined reference to `_imp__key'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x329):code.c: undefined reference to `_imp__key'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x346):code.c: undefined reference to `rest'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x35a):code.c: undefined reference to `destroy_bitmap'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x36b):code.c: undefined reference to `destroy_bitmap'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x37c):code.c: undefined reference to `destroy_bitmap'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x3a7):code.c: undefined reference to `_WinMain'
C:\WINDOWS\TEMP\cczbW9fb.o(.text+0x3c7):code.c: undefined reference to `clear_bitmap'

/////////////////////////////////////////////////////////////

explication ??? le bug vient d'où ?

bon je redl et je vous tiens au courant, mais si vous avez une réponse ;-)

PS : j'ai lu ton cours sur OpenGl, mais comme j'avasi déjà dev, je l'ai pas re Dl, et c'est pas marqué qu'il fallait le faire ;-)
Messages postés
1267
Date d'inscription
mercredi 1 janvier 2003
Statut
Membre
Dernière intervention
28 février 2007
3
Rectification : ceci n'est pas mon site, mais c'est le site d'AmK, et j'ai écrit seulement les tuts sur OpenGL, les tuts sur Allegro ont été écrits soit par lui, soit par OSM3K.

En ce qui concerne tes erreurs c'est dû au fait que tu n'as pas linké ton projet avec les libs d'Allegro, c'est dans les options du projet, t'as une zone exprès pour ça, et un bouton qui te permet de choisir un fichier du style de "liballegro.a", qui doit se trouver quelque part dans ton dossier C:\Dev-Cpp\Lib.

En ce qui concerne OpenGL, t'arrives à le faire marcher ou pas alors?

---------------------------------------------------------
Patience et longueur de temps font plus que force ni que rage....
Coucous flingueurs 3D : http://www.freewebs.com/cf3d/
Un concours de prog graphique, ça vous dit? c'est sur Coder-Studio : http://www.coder-studio.com/forums/index.php?showtopic=64
Messages postés
546
Date d'inscription
vendredi 13 février 2004
Statut
Membre
Dernière intervention
9 janvier 2008
1
Deja pour un prog utilisant allegro il fo creer un prtojet allegro dans devcpp .

Et tous ces linker errors viennent du fait que t'as pas lier la lib d'allegro a ton projet: liballeg.a
Messages postés
79
Date d'inscription
dimanche 1 juin 2003
Statut
Membre
Dernière intervention
11 mai 2007

OK
Merci, OpenGl et et Allegro ont l'air de fonctionner, à priori c'est bon.

++