Passage de variable dans un lien [Résolu]

Signaler
Messages postés
23
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
20 mai 2005
-
Messages postés
23
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
20 mai 2005
-
Bonjour à tous,

J'ai une page .asp contenant certains objets me permettant de définir certains paramètres pour l'affichage d'un calendrier (c'est un code source que j'ai trouvé sur le net). Tout dépend à partir de quel lien l'utilisateur ouvre cette page, les paramètres devraient être différents.

Pour savoir d'où il ouvre la page, j'utilise une variable dans le lien :
Lien 1 : [Calendriers/swaspcal/SWAspCal.asp?lstSECURITE=<% =Response.write( " class="menu2">
Lien 2 : ] " class="menu2">

Ensuite, dans la page .asp, j'entre les requêtes suivantes pour paramétrer mon objet :
Obj.NoSWACLink = true
if Request.QueryString("IstSECURITE") = "HELPDESK" then
Obj.NoSWACLink = false
end if

Obj.NoSWACLink = true
if Request.QueryString("IstSECURITE") = "PUBLIC" then
Obj.NoSWACLink = false
end if

Obj.Execute
Set Obj = Nothing

Toutefois, ça ne fonctionne pas, pas de message d'erreur, mais rien ne marche !?!

Est-ce que qqn est susceptible de m'aider ? Merci d'avance !

2 réponses

Messages postés
224
Date d'inscription
vendredi 14 septembre 2001
Statut
Membre
Dernière intervention
14 juillet 2006

Ben une fois, tu écrit lstSECURITE avec un L minuscule, et une fois avec un I majuscule. Du moins il me semble
Messages postés
23
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
20 mai 2005

Oui, c'est ça...
Désolée de vous avoir embêté pour une faute d'ortho.
Mais en tout cas, mille mercis. :blush)