Probleme de link

Résolu
sparetime
Messages postés
34
Date d'inscription
mercredi 30 juillet 2003
Statut
Membre
Dernière intervention
17 août 2004
- 20 juil. 2004 à 11:12
magic_Nono
Messages postés
1878
Date d'inscription
jeudi 16 octobre 2003
Statut
Membre
Dernière intervention
16 mars 2011
- 20 juil. 2004 à 18:53
bonjour
j'obtiens des erreurs de link du genre

Communication.obj : error LNK2001: unresolved external symbol __imp__gethostbyaddr@12
Communication.obj : error LNK2001: unresolved external symbol __imp__inet_addr@4
Communication.obj : error LNK2001: unresolved external symbol __imp__gethostbyname@4
Communication.obj : error LNK2001: unresolved external symbol __imp__WSAStartup@8
Communication.obj : error LNK2001: unresolved external symbol __imp__WSACleanup@0
Communication.obj : error LNK2001: unresolved external symbol __imp__closesocket@4

mais pourtant j fait un iclude winsock.h et je n'ai pas d'erreurs et je crois que ces trucs se trouvent la dedans

si vous pouvez m'aider alors merci

3 réponses

cs_AlexMAN
Messages postés
1536
Date d'inscription
samedi 21 décembre 2002
Statut
Membre
Dernière intervention
24 mai 2009
2
20 juil. 2004 à 11:21
Tu as oublié de linker la lib winsock :

si t sous vc++, #pragma comment(lib, "ws2_32.lib") //pour version 2

#pragma comment(lib, "wsock32.lib") //pour version 1

Si tu n'es pas sous vc++, fo regler ca ds les options du projet..

++

Alhexman
3
sparetime
Messages postés
34
Date d'inscription
mercredi 30 juillet 2003
Statut
Membre
Dernière intervention
17 août 2004

20 juil. 2004 à 11:44
merci bcp
ca a résolu mon pb
0
magic_Nono
Messages postés
1878
Date d'inscription
jeudi 16 octobre 2003
Statut
Membre
Dernière intervention
16 mars 2011
1
20 juil. 2004 à 18:53
conseil pour d'autre ayant le mm pb:

Spare>valide la rep...

Ciao
Magic Nono: l'informagicien!
0