URGENT : copyfile, permission refusée

Signaler
Messages postés
22
Date d'inscription
vendredi 18 janvier 2002
Statut
Membre
Dernière intervention
31 janvier 2002
-
LucAleFel
Messages postés
1
Date d'inscription
dimanche 18 décembre 2005
Statut
Membre
Dernière intervention
18 décembre 2005
-
Salut,

J'essaie de prendre un fichier dans un dossier et de la copier dans un autre.

J'ai CommonDialog1.ShowOpen qui permet à l'utilisateur de choisir son fichier.

Ensuite j'ai

Dim fso As New FileSystemObject
Dim fImage As

Set fso = New FileSystemObject

fso.CopyFile CommonDialog1.FileName, DOSSIER_IMAGES_PATH, True

A l'exécution, ça plante sur la dernière ligne avec le message d'erreur "Permission refusée".

Pourtant, les deux dossiers sont sur le même disque et j'ai essayé de le faire à la main, sans problème. J'ai vérifié les droits, y a everyone avec full control et system avec full control.

Je suis bloqué là...

Merci d'avance
Lilian

5 réponses

Messages postés
3
Date d'inscription
jeudi 17 janvier 2002
Statut
Membre
Dernière intervention
18 janvier 2002

Hmmmm tu as regardé en debug la valeur exacte de ton DOSSIER_IMAGES_PATH ?
Messages postés
22
Date d'inscription
vendredi 18 janvier 2002
Statut
Membre
Dernière intervention
31 janvier 2002

Ouais, c'est une bête constante du style C:\TRAVAIL\réalisation\1.0\gallerie

Merci pour ta réponse
Lilian
Messages postés
3
Date d'inscription
jeudi 17 janvier 2002
Statut
Membre
Dernière intervention
18 janvier 2002

Essaie avec un \ de plus à la fin
Messages postés
22
Date d'inscription
vendredi 18 janvier 2002
Statut
Membre
Dernière intervention
31 janvier 2002

C'était ça ! Merci pour ton aide
A bientôt
Lilian
Messages postés
1
Date d'inscription
dimanche 18 décembre 2005
Statut
Membre
Dernière intervention
18 décembre 2005

J'avais le même problème que j'essayais de résoudre depuis plus de 2 jours ... Après plusieurs requêtes sur une multitude de moteurs de recherche, je suis tombé par «miracle» sur ce forum ...

Comme mots-clé, j'ai utilisé «copy file» et «permission refusée» alors qu'avant je faisais mes recherches avec le code d'erreur retourné par IIS ...

C'était donc le fameux «\» qui manquait au nom de mon répertoire d'arrivée ... ... un gros merci à celui qui a trouvé cette solution ...


Et je viens tout juste de m'inscrire à ce forum ... j'ai l'impression que je vais en apprendre beaucoup ... et j'espère que je pourrai moi aussi faire mon humble contribution !

Luc-Alexandre


Architecte de sites web (Web Designer)

Sherbrooke (Québec) Canada