Aide sur excel je ne touve pas la formule

valcleseb Messages postés 1 Date d'inscription samedi 26 juin 2004 Statut Membre Dernière intervention 27 juin 2004 - 27 juin 2004 à 00:00
sagoirand Messages postés 6 Date d'inscription lundi 9 février 2004 Statut Membre Dernière intervention 27 juin 2004 - 27 juin 2004 à 11:58
Bonjour a tous,
novice sous excel, j'ai créer un tableau de pointage d'heure de travail, j'ai créer quatre colonnes (deux colonnes "heure de début" et deux "heure de fin"), une cinquieme colonne qui totalise le nombre d'heure effectué, et c'est là que tout ce complique, je voudrais créer trois autres colonnes qui analyse et calcule la valeur donnée.la 1ere "taux", 2eme "nbr heure nuit a", 3eme "nbr heure nuit v". exemple:
la colonne A = H.debut matin
B = H.fin matin
C = H.début apm
D = H.fin apm
E = total heure dans la journée
F = selectionne la cellule (par rapport à la valeur donnée "a" ou "v")dans laquelle elle correspond soit G ou H
G = nbr H. de nuit au taux "a"
H = nbr H. de nuit au taux "v"

disons que de 0:00 à 8:00 et de 20:00 à 24:00 sont des heures de nuit.
que la journée effectuée est 5:30 à 21:45 au taux "v"
je voudrais trouver la formule qui me dit qu'il y a "4:15" dans la celulle H en ayant toujours dans la cellule E "16:15"
ou dans la celulle G si le taux est "a".
Merci de votre aide.
VALCLESEB
VALCLESEB

2 réponses

cs_liquide Messages postés 1016 Date d'inscription samedi 22 mars 2003 Statut Membre Dernière intervention 24 juin 2008
27 juin 2004 à 00:26
http://www.vbfrance.com/forum.v2.aspx?ID=248949&nb=0, ca c'est le 1ere post .... sans réponse mais identique a celui ci !!!

si on avait pas la réponse avant, on ne l'a toujours pas maintenant !!!
ca ressemble plus a de l'utilisation d'excel qu'a de la programmation VB. Je ne vois pas en quoi nous pouvons t'aider en ce qui concerne VB. Si c'est de la prog explique dasn ton prog ou ca bloque dans ton code. Apres, peut etre qu'il y en a qui sont fort en utilisation d'excel, va savoir.

bonnne prog si tu prog biensûr
liquide
0
sagoirand Messages postés 6 Date d'inscription lundi 9 février 2004 Statut Membre Dernière intervention 27 juin 2004
27 juin 2004 à 11:58
aaristote
Bjr

Sur excel deux formules conditionnelles suffisent

tu definis 2 constantes
insertion nom definir
Par ex a = 24
b= 00
En A1 = prise de poste 20:00
en B1 = fin poste 5:00

en C1 tu calcules les heures jusqu' à Minuit
C1 =SI(A1>B1;a-A1;B1-A1)

en D1 les heures après minuit
D1 =SI(B1<A1;B1-b;0)

A adapter en fct de ta mise en page

Cordialement
0