Problème avec un formulaire word

Dragonlady Messages postés 1 Date d'inscription mercredi 23 juin 2004 Statut Membre Dernière intervention 23 juin 2004 - 23 juin 2004 à 20:30
maydaybigfoot Messages postés 4 Date d'inscription lundi 8 décembre 2003 Statut Membre Dernière intervention 28 août 2006 - 14 oct. 2005 à 12:21
Bonjour!
J'aimerais avoir quelque indice qui pourrait faire disparaître mon petit problème.
J'ai confectionné un ormulaire sous Word, qui contient des listes déroulantes. Chacune de ces listes est prise en charge par un code VB pour généré les liste de choix muliples. Tout fonctionne bien sur mon terminal, mais personne peux s'en servir si je l'envois par email et même s'ils accèdent à mon poste via un réseau local...

Il ne demande pas non plus s'il doit activer les macros dès l'ouverture du document...
Je crois bien que c'est le problème, mais je ne sais pas comment lui dire de les activers dès le début...

Merci de me venir en aide
(urgent!)

2 réponses

cs_CanisLupus Messages postés 3757 Date d'inscription mardi 23 septembre 2003 Statut Membre Dernière intervention 13 mars 2006 18
23 juin 2004 à 21:25
Salut,

Si ton document Word, macros comprises, est transmise à quelqu'un d'autre, par e-mail ou autre, ça devrait fonctionner sauf si :

1 - Tes destinataires ont désactivé en permanence l'activation des macros : ça je ne sais pas comment le réactiver
2 - Pour s'exécuter, ta ou tes macros font appel à des bases de données ou d'autres documents inaccessibles à partir de leur PC (dossiers partagés, droits d'accès,...)
3 - Ou alors, il y a un anti-virus qui interdit toute exécution de macro Word.

a suivre .....

Cordialement

CanisLupus
0
maydaybigfoot Messages postés 4 Date d'inscription lundi 8 décembre 2003 Statut Membre Dernière intervention 28 août 2006
14 oct. 2005 à 12:21
Ou plus simplement tu as sauvegardé ta macro dans ton normal.dot et pas dans le document Word...

Vérifie sur ton éditeur VBS
0