Gros problème avec Crystal Report sous VB.Net

tofbzh29272 Messages postés 2 Date d'inscription jeudi 22 avril 2004 Statut Membre Dernière intervention 15 juillet 2005 - 14 juin 2004 à 15:28
maroc1enforce Messages postés 9 Date d'inscription lundi 17 décembre 2007 Statut Membre Dernière intervention 16 mars 2009 - 30 sept. 2008 à 14:31
Bonjour à tous ! Je vous écris car j'ai un gros souci. Je conceptionne une application qui fonctionne sous VB.Net et récupère des données par une base sous Access 2000. Cette application me permet d'obtenir des documents de sortie imprimés. Et c'est là le problème...

Au fait, quand je crée un état Crystal Report, je déclare une requête, un dataset, etc. Quand je fais appel à une seule table, l'état fonctionne très bien. MAIS, quand je fais appel à plusieurs tables en relations, voici ce qui se passe :
- le formulaire se lance sans problème apparent
- [b]apparition d'une messagebox où il est écrit ceci : "Erreur du moteur de recherche" en titre et en texte, "c:\docume~1\christ~1[ma session de docs]\locals~1\temp\temp_2a242a28-ccaa-4f3a-a734-0288636d762a.rpt"

Voilà ! C'est tout (enfin, si on veut !). Je vous remercie d'avance pour un renseignement et vous fécilite de votre site car il est superble !!)

@+ Tof

2 réponses

gaa179 Messages postés 361 Date d'inscription mercredi 21 mai 2003 Statut Membre Dernière intervention 12 novembre 2009 2
15 juin 2004 à 08:31
Salut,

Avec Vb.net, je ne peux pas t'aider. Mais regarde sur le site CR: http://support.businessobjects.com/. Tu devrais trouver la solution à ton problème

A+
maroc1enforce Messages postés 9 Date d'inscription lundi 17 décembre 2007 Statut Membre Dernière intervention 16 mars 2009
30 sept. 2008 à 14:31
essayes de ne pas utiliser une requette de plus de 2 jointures
et le dataset doit contenir ts les resultats des requettes utilisées
par exemple au lieu de faire une select from plusieurs tables
tu fait 2 requettes   select ou plus  qui chargent le meme dataset
Rejoignez-nous