Utilisation d'une Base de donnée sur un réseau local

guilhemrostain Messages postés 12 Date d'inscription jeudi 25 mars 2004 Statut Membre Dernière intervention 12 août 2004 - 9 juin 2004 à 18:25
foralg Messages postés 1 Date d'inscription lundi 21 décembre 2009 Statut Membre Dernière intervention 22 mai 2011 - 22 mai 2011 à 19:34
Bonjour, je vous expose directement mon problème :
Pour mon application sous Delphi 7 j'utilise une connection à une base de donnée. J'ai testé avec une base Access en locale et ca marche.
Le problème se pose lorsque j'utilise la vraie base qui est sur le serveur.
Pour tester si je peux me connecter à la base j'utilise l'explorateur de Base de données de Delphi. Il détecte la base... mais pas les tables !

Je pense que le problème vient du fait que sous Access les tables ne sont pas des table "simples" mais des tables "ODBC attaché". (l'icone des tables n'est pas le meme).

Pensez vous que Delphi peut gérer des tables sur un réseau ?
Ou plus simple... que je puisse convertir les tables que j'ai attachée sous Access en table "normales"?

2 réponses

guilhemrostain Messages postés 12 Date d'inscription jeudi 25 mars 2004 Statut Membre Dernière intervention 12 août 2004
10 juin 2004 à 15:33
Problème résolu ! Il suffisait d'importer les tables sous Access et non pas de les lier...
0
foralg Messages postés 1 Date d'inscription lundi 21 décembre 2009 Statut Membre Dernière intervention 22 mai 2011
22 mai 2011 à 19:34
je vous remercie pour votre travail
0