Erreur automation

Signaler
Messages postés
3
Date d'inscription
samedi 13 mars 2004
Statut
Membre
Dernière intervention
12 janvier 2008
-
Messages postés
2
Date d'inscription
samedi 21 décembre 2002
Statut
Membre
Dernière intervention
7 juillet 2005
-
probleme avec .exe (source VB6)
j'ai le message d'erreur suivant :

Erreur d'execution '-2147417848 (80010108)':

erreur automation
L'objet invoque s'est deconnecte de ses clients.

L'erreur apparait lors de l'execution du programme compile (.exe). Elle n'apparait pas quand je teste le programme sous editeur VB6.

Je ne comprends plus rien . . . . .

HELP !
A voir également:

3 réponses

Messages postés
80
Date d'inscription
vendredi 14 mai 2004
Statut
Membre
Dernière intervention
2 octobre 2009

salut

bon j'ai eu le même problème il y a peu ....
Pour ma part c'était un problème de perte de pointeur sur mes objets. En effet j'essayais de rappeler un objet qui était détruit.
Pour plus détails :
je faisais apparaitre une fenetre que l'utilisateur était capable de fermer via la croix de fermeture.Un bouton me permettait de faire apparaitre les fenetres en mode visible=false.Cependant lorsque je cliquais sur le bouton pour faire apparaitre la fenetre et que celle-ci avait été detruite le message d'erreur apparaissait.
Pour resoudre ce pb il te faut être bcp plus defensif dans le code.
Pour ma part j'ai empecher la destruction des fenetres en faisant disparaitre la croix.

Voilà j'espere que tu trouveras une solution à ton problème.

Sev
Messages postés
1
Date d'inscription
vendredi 16 juillet 2004
Statut
Membre
Dernière intervention
17 juillet 2004

Lart63
j'ai le message d'erreur :
microsoft visual basic
erreur d'execution 2147417848 (80010108)
erreur automation
l'objet invoqué s'est déconnecte de ses clients

à la première instruction objet.show

Une solution temporaire consiste à exporter et supprimer ce Userform, puis à le réimporter.

Y-a-t-il une solution définitive ?
Merci
Messages postés
2
Date d'inscription
samedi 21 décembre 2002
Statut
Membre
Dernière intervention
7 juillet 2005

en fait quel object s'agit-il? j'ai eu la même erreur un composant pour
les reports mais lorsque j'ai fait un New , les choses ont marchées.



Essaye de fair un 'set object = New .....' avant de faire le object.show