SetMask sur une image

niconaldo Messages postés 17 Date d'inscription lundi 17 novembre 2003 Statut Membre Dernière intervention 9 août 2004 - 30 avril 2004 à 12:09
nepomuk Messages postés 17 Date d'inscription mercredi 3 juillet 2002 Statut Membre Dernière intervention 3 décembre 2005 - 25 nov. 2004 à 10:02
Bonjour,

J'ai un problème pour masquer une image que je charge à l'aide d'un loadMovie.

J'ai un clip nommé cadre1 sur ma scène, qui est un carré représentant le cadre dans lequel on verra seulement un bout de l'image.

J'ai écrit ca :

_root.loadMovie("cartes/autre35.jpg");
_root.setMask(_root.cadre1);

...et mon image apparait en entier.

Si vous avez une idée...

3 réponses

niconaldo Messages postés 17 Date d'inscription lundi 17 novembre 2003 Statut Membre Dernière intervention 9 août 2004
3 mai 2004 à 08:09
J'ai oublié de préciser, sans faire le loadMovie, le masque marche, par contre quand l'image est chargée pas moyen de la masquer.
0
nepomuk Messages postés 17 Date d'inscription mercredi 3 juillet 2002 Statut Membre Dernière intervention 3 décembre 2005
11 nov. 2004 à 17:17
Je suis désolé de ne pas pouvoir t'aider, et ça pour une bonne raison, c'est que j'ai le même problème.
J'espère que quelqu'un de compétent va bientôt passer par là pour nous aider.

--- L'ISIMA ce n'est vraiment pas n'importe quoi ---
0
nepomuk Messages postés 17 Date d'inscription mercredi 3 juillet 2002 Statut Membre Dernière intervention 3 décembre 2005
25 nov. 2004 à 10:02
J'ai enfin réussi à masquer mon animation importée par loadMovie mais vu que sa ressemble assez à ce que tu as déjà essayé je sais pas si ca va t'etre d'un grand secours.

Ce que j'ai fait :
_root.strip_layer.setMask(fond);

_root.strip_layer : animation importée dans _root
fond : instance d'un clip qui se situe dans la frame comportant le code ci dessus

J'espere que ca t'aidera

--- L'ISIMA ce n'est vraiment pas n'importe quoi ---
0