De l'HTML avec mail() ?

Drazounet Messages postés 63 Date d'inscription jeudi 30 octobre 2003 Statut Membre Dernière intervention 27 mars 2008 - 10 mars 2004 à 19:02
jojomillenium Messages postés 136 Date d'inscription samedi 1 mai 2004 Statut Membre Dernière intervention 26 mai 2007 - 28 oct. 2006 à 10:58
Salut à tous ;)

J'essaie actuellement de faire un petit programme de mailing en PHP à l'aide de la fonction mail().

Mais, lorsque j'essaie d'intégrer une image à mon mail (à l'aide de code HTML), celà ne fonctionne ni sur hotmail, ni sur outlook. Pouvez-vous m'indiquer comment faire ? En sachant bien entendu que je ne désire pas envoyer l'image en elle-même, mais un lien qui ouvrera l'image lors de la lecture du message.

Merci d'avance :big)

A++ all
Drazic

13 réponses

XsatanaX Messages postés 122 Date d'inscription samedi 6 mars 2004 Statut Membre Dernière intervention 5 mai 2004
11 mars 2004 à 06:56
Pour passer du HTML dans la fonction mail:::

mail("$Femail","$Fsujet",$codehtml,"From:ton@mail.com\nContent-Type: text/$Fformat; charset="iso-8859-1"\n"); }
XsatanaX Messages postés 122 Date d'inscription samedi 6 mars 2004 Statut Membre Dernière intervention 5 mai 2004
11 mars 2004 à 06:57
decidement le matin... sans l'acolade}

mail("$Femail","$Fsujet",$codehtml,"From:ton@mail.com\nContent-Type: text/$Fformat; charset="iso-8859-1"\n");
Drazounet Messages postés 63 Date d'inscription jeudi 30 octobre 2003 Statut Membre Dernière intervention 27 mars 2008
11 mars 2004 à 17:50
Merci beaucoup :big)
Drazounet Messages postés 63 Date d'inscription jeudi 30 octobre 2003 Statut Membre Dernière intervention 27 mars 2008
11 mars 2004 à 18:10
Excuse moi, mais tu entend quoi par la case Type: text/$Fformat (je dois mettre quoi dans la variable ??)

Merci encore ;)

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Drazounet Messages postés 63 Date d'inscription jeudi 30 octobre 2003 Statut Membre Dernière intervention 27 mars 2008
11 mars 2004 à 18:11
Excuse moi, mais tu entend quoi par la case Type: text/$Fformat (je dois mettre quoi dans la variable ??)

Merci encore ;)
Drazounet Messages postés 63 Date d'inscription jeudi 30 octobre 2003 Statut Membre Dernière intervention 27 mars 2008
11 mars 2004 à 19:14
Je crois avoir trouvé, j'ai essayé "Type: text/html" et j'arrive à envoyer des mail en HTML..

J'arrive à faire un lien en HTML, mais par contre je n'arrive pas à afficher les images ! Y a-t-il une solution ?

Désolé de mon incompréhension :shy)
XsatanaX Messages postés 122 Date d'inscription samedi 6 mars 2004 Statut Membre Dernière intervention 5 mai 2004
12 mars 2004 à 02:43
Bien sur,
$Fformat = 'HTML';

Je ne comprend pas pour l'image?
Tu desire envoyer une image avec ton mail?
Merci d'avance si tu es 1 peu plus clair...
Drazounet Messages postés 63 Date d'inscription jeudi 30 octobre 2003 Statut Membre Dernière intervention 27 mars 2008
12 mars 2004 à 07:21
Je cherche à insérer des images à l'aide du format HTML.

Mais voilà, sur Outlook, l'image ne s'affiche pas (il y a une croix qui indique une image non-affichée) et sur MSN il n'y a même pas la croix ! Alors que le chemin est correct et complet (commence par http://).

En résumé, le code HTML fonctionne dans les e-mail, mais je n'arrive pas à appeler des images à l'aide de l'HTML
XsatanaX Messages postés 122 Date d'inscription samedi 6 mars 2004 Statut Membre Dernière intervention 5 mai 2004
12 mars 2004 à 08:59
Celui peut provenir de ton hébergeur pour limiter les spams,
renseigne toi.
Drazounet Messages postés 63 Date d'inscription jeudi 30 octobre 2003 Statut Membre Dernière intervention 27 mars 2008
12 mars 2004 à 12:55
Je ne pense pas car je peux envoyer 1000 mail à la suite sans problèmes, donc pourquoi ne pas authoriser l'envoi d'images ;)
XsatanaX Messages postés 122 Date d'inscription samedi 6 mars 2004 Statut Membre Dernière intervention 5 mai 2004
12 mars 2004 à 20:14
parceque 1000 mails de 10ko c pas pareil que 1000 mails
avec des images donc peut etre de 50ko.

Perso pour 1000 mails je vois direct avec l'herbergeur,
J'envoie pas pas 1000 mails en 30 secondes! si yen a que 100 qui sont passés, ca pose un gros gros probleme..

Donc je continue, contact ton hebergeur, parle lui de SHEDULEUR de scripts pour l'envoie de tes mass mails puis
demande lui au sujet des envoie images..

...
Drazounet Messages postés 63 Date d'inscription jeudi 30 octobre 2003 Statut Membre Dernière intervention 27 mars 2008
13 mars 2004 à 00:01
Ok, merci, je vais donc contacter mon hebergeur :)
jojomillenium Messages postés 136 Date d'inscription samedi 1 mai 2004 Statut Membre Dernière intervention 26 mai 2007
28 oct. 2006 à 10:58
hello!

Si jamais pour afficher une image tu dois mettre l'URL de l'image correspondante dans la source!

exemple :


voila!


J'espere t avoir aider meme si c'est 2 ans et demi plus tard :P
Rejoignez-nous