Problème d'espace...

Signaler
Messages postés
17
Date d'inscription
dimanche 29 septembre 2002
Statut
Membre
Dernière intervention
14 février 2006
-
Messages postés
289
Date d'inscription
jeudi 5 octobre 2006
Statut
Membre
Dernière intervention
11 juin 2010
-
Bonjour voilà j'ai un problème qui me turlupine.
J'affiche des photos grace a un requete et tout le toutim, mais si j'ai des photos avec un nom du style
"MA PHOTO.jpg", avec des mots séparés par un espace, la photo ne s'affiche pas car çà foire.
J'avais déjà eu ce probleme mais me souviens plus comment corriger çà!!! Mis à part changer le nom des photos bien entendu! LOL
Merci de m'aider.
Chaque connaissance est une réponse à une question.

3 réponses

Messages postés
728
Date d'inscription
jeudi 20 juin 2002
Statut
Membre
Dernière intervention
7 novembre 2007
2
essaie de remplacer l'espace par %20 dans le nom de ton img

:big) Sylvain [[mailto:eax@eax-online.com email]] [homepage] [myCV]
Messages postés
17
Date d'inscription
dimanche 29 septembre 2002
Statut
Membre
Dernière intervention
14 février 2006

Ouais heu je sais çà, mais c'est pas une solution quand même...
Je cherche une solution plus scientifique ;-)

Chaque connaissance est une réponse à une question.
Messages postés
289
Date d'inscription
jeudi 5 octobre 2006
Statut
Membre
Dernière intervention
11 juin 2010
3
tu a essayer avec
str_replace(" ","%20","le nom de ta photo");
bien sur avant d'afficher ta photo
j'espere avoir pu t'aider


Personne ne peut se permettre de juger l'autre....