Alt-GR et formulaire VBA : un cas unique !!!! [Résolu]

Signaler
Messages postés
20
Date d'inscription
lundi 5 janvier 2004
Statut
Membre
Dernière intervention
7 août 2009
-
Messages postés
20
Date d'inscription
lundi 5 janvier 2004
Statut
Membre
Dernière intervention
7 août 2009
-
Bon à tous les bidouilleurs de la ligne de code !

J'ai une énigme à vous soumettre :
Je développe un formulaire en VBA avec des champs de saisie (classique), plus quelques objets importés : WebBrowser, TreeView, ImageList et COmmonDialog.

Le hic, c'est que je ne peux saisir aucun caractère combiné avec la touche "Alt-Gr" (comme un @ ou un |) dans mes zones de saisie, le curseur passe de "saisie texte" en "flèche".

Cependant, l'évènement KeyPress me reconnait bien mon @ ou mon | ...

Auriez-vous une idée ?

Merci grandement !!!!!

AmigaINC
-------------------------------------
<<->> Back for the future <<->>
-------------------------------------

1 réponse

Messages postés
20
Date d'inscription
lundi 5 janvier 2004
Statut
Membre
Dernière intervention
7 août 2009
1
Re-bonjour !

Je viens de trouver la source demes problèmes : l'objet WebBrowser !!!!

Ce phénomène intervient après que le WebBorwser soit initialisé avec une page ; avant (quand le webbrowser n'a pas encore visité de page), les @ et les | marchent bien...

Bonne journée à vous tous !!

AmigaINC
-------------------------------------
<<->> Back for the future <<->>
-------------------------------------
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 82 internautes nous ont dit merci ce mois-ci