Delphi pasword et user Oracle dans le code [Résolu]

Messages postés
3
Date d'inscription
lundi 15 décembre 2003
Statut
Membre
Dernière intervention
17 décembre 2003
- - Dernière réponse : sharifcrd
Messages postés
37
Date d'inscription
lundi 23 août 2010
Statut
Membre
Dernière intervention
18 avril 2014
- 25 avril 2011 à 09:53
Bonjour,
je connecte une db Oracle 92i depuis delphi7, le soucis, c'est qu'à l'activation apparaît une fenêtre qui demande les user-password d'oracle. il est normal que le système ait besoin de ces infos pour connecter la db, mais comment puis-je introduire celles-ci dans le code pour que cela soit transparent (pas de fenêtre de demande)
merci

Yves
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
4580
Date d'inscription
samedi 19 janvier 2002
Statut
Modérateur
Dernière intervention
9 janvier 2013
24
3
Merci
Voir TDatabase.OnLogin dans l'aide en ligne de Delphi.
May Delphi be with you

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 189 internautes nous ont dit merci ce mois-ci

Commenter la réponse de cs_Delphiprog
Messages postés
3
Date d'inscription
lundi 15 décembre 2003
Statut
Membre
Dernière intervention
17 décembre 2003
0
Merci
Super, ç'est tout ce qu'il me fallait, merçi beaucoup

Yves
Commenter la réponse de cs_yves_
Messages postés
37
Date d'inscription
lundi 23 août 2010
Statut
Membre
Dernière intervention
18 avril 2014
0
Merci
sharif
sharif
j'essai de connecte mon appliacation sous delphi 7 avec une database oracle 10g
pour cela
1-- j'ai installé et configuré oracle server 10g v10.2.0 sur une machine server (server 2003)
2-- j'ai installé et configuré oracle client 10g v10.2.0 sur ma machine client (xp sp3
3-- j'ai configuré l' ODBC comme suivant:
Data Source Name = MAIN_MATE
TNS Service Name = MYTABLE
User ID = SHARIF
aprés j'ai cliqué sur test connection et j'ai fourni le mot de passe exacte et la connection et etablie avec succés.

sur DELPHI 7
j'ai un composant TTable configure comme ceci
DataBaseName = MAIN_MATE
TableName = DB_MATERIEL
Active = True
jusque là c bon
mais le probleme c que a chaque execution de cette application un message appret me demandant de resaisire le USERID et le mot de passe malgré que j les ai fournit avant
ma qustion est que doit je faire pour evite d'avoir ce message a chaque foit
merci d'avance

comment regles ce problem je voudrais avoir une repence detaillée
Commenter la réponse de sharifcrd