PHPEXCEL impossible de lire le contenu d'une ligne avec formule [Résolu]

Messages postés
96
Date d'inscription
mardi 18 août 2009
Statut
Membre
Dernière intervention
14 août 2013
- - Dernière réponse : cs_didine13
Messages postés
96
Date d'inscription
mardi 18 août 2009
Statut
Membre
Dernière intervention
14 août 2013
- 8 mai 2013 à 16:02
Bonjour,

Sur phpexcel je peu tout lire sur toutes les colonnes sauf la dernière colonne AD, je bloque dessue car je ne sais pas lire une colonne qui contient une formule.

Le fichier Excel est un fichier fournit par mon fournisseur, donc je suis obliger de l’utilisé comme il est.

La colonne AD contient la description
Exemple de la ligne 3 Colonne AD : *HDMI HighSpeed et compatibilité HDCP.

Mais quand j’ouvre le fichier excel sur mon pc et que je fais bouton droit pour copier le texte (juste pour tester car je ne travail que sur php), magie j’ai la description complète (je ne sais pas d’où elle sort lol), mais ca m’intéresse beaucoup.

Voir le résultat de la copie

[b]
"*HDMI HighSpeed et compatibilité HDCP
*Vidéo HD non compressées jusqu'à 1080p @ 60Hz à 100m
*Transfers video, audio et HDCP sur un cordon RJ45 !
*Audio TrueHD, DTS-HD Master Audio
*Supporte la 3D (avec périphériques 3D)

Emetteur
entrée HDMI
sortie "
/b
Les colonnes contiennent la même formule sauf A3 qui change : A3 ligne 3, A4 ligne 4 etc…
=RECHERCHEV(A3;'\\SRV004\Doc_CUC\INFORMATIQUE\Scripts\[BaseFTPProduit.xlsm]Caracteristiques'!A$7:B$15000;2;FAUX)

Mon echo donne ceci
// =VLOOKUP(A3,#REF!,2,FALSE)

require_once( $this->moduleDir.'PHPExcel.php' );
require_once( $this->moduleDir.'PHPExcel/Calculation.php' );
require_once( $this->moduleDir.'PHPExcel/Cell.php' );
$cacheMethod  = PHPExcel_CachedObjectStorageFactory:: cache_to_phpTemp;
$cacheSettings array('memoryCacheSize'> '16MB');
PHPExcel_Settings::setCacheStorageMethod($cacheMethod, $cacheSettings);
$DATAPHPExcel = PHPExcel_IOFactory::load($filename);
$loadedSheetNames = $DATAPHPExcel->getSheetNames();
$DATAPHPExcel->setActiveSheetIndex(0);
$ColExcel = $DATAPHPExcel->getActiveSheet()->toArray(null,false,false,true);
$data =array();
$data['UPdate'] =  date( 'Y-m-d H:i:s') ;
$nbligne = count( $ColExcel );

for( $i = 1 ; $i <= $nbligne ; $i++ )
{
if ($ColExcel[$i]['R'] != '') 
{
$data['1'] = $ColExcel[$i]['B']; // ok
$data['2'] = $ColExcel[$i]['D']; // OK
$data['3'] = $ColExcel[$i]['E']; // OK
$data['4'] = $ColExcel[$i]['C']; // OK
$data['5'] = $ColExcel[$i]['G']; // OK
$data['6'] = $ColExcel[$i]['M']; // OK
$data['8'] = $ColExcel[$i]['Q']; // OK
$data['9'] = $ColExcel[$i]['S']; // OK
$data['11'] = $ColExcel[$i]['U']; // OK

//	etc..
//	$data['description'] = $ColExcel[$i]['AD']; // Impossible à récupérer l'erreur // =VLOOKUP(A3,#REF!,2,FALSE)

echo ($ColExcel[$i]['AD']).	'
'; // pour voir le resultat						
}
}


Merci d'avance
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
96
Date d'inscription
mardi 18 août 2009
Statut
Membre
Dernière intervention
14 août 2013
3
Merci
problème résolut

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 196 internautes nous ont dit merci ce mois-ci

Commenter la réponse de cs_didine13