Erreur de complilation [Résolu]

Messages postés
51
Date d'inscription
lundi 2 mars 2009
Dernière intervention
5 octobre 2015
- - Dernière réponse : Whismeril
Messages postés
12371
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
11 décembre 2018
- 30 avril 2013 à 16:05
Bonjour à tous

J'ai un petit problème avec mon code , J'aimerai qu’une personne puisse me dire quoi faire dans tel cas
Je reçois un message d'erreur du genre : Erreur 1 'GestionPaie.GesCompte.SelectData(string)' : tous les chemins de code ne retournent pas nécessairement une valeur C:\Users\jsc\Desktop\GestionPaie\GestionPaie\GesCompte.cs 64 32 GestionPaie

et la fonction qui génère l'erreur est :
public OleDbDataReader SelectData(string requette)
         {
             try
             {
                 OuvertureConn();
                 Cmd = new OleDbCommand();
                 Cmd.Connection = Conn;
                 Cmd.CommandText = requette;
                 return Cmd.ExecuteReader();  

             }
             catch (OleDbException OldbExcep)
             {
                 ResultatConnection = OldbExcep.Message.ToString();
             }
             
         
        
       
         }


Merci
Afficher la suite 

Votre réponse

5 réponses

Meilleure réponse
Messages postés
14319
Date d'inscription
vendredi 14 mars 2003
Dernière intervention
11 décembre 2018
3
Merci
Bonjour,

C'est habituellement un avertissement, pas une erreur, tu as dû cocher la case "Traiter les avertissement comme des erreurs".
Ce message est normal, si tu passes par ton Catch, il n'y a pas d'instruction Return.

v----Signature--------v----------------------------------------------
[list=ordered][*]Pour poser correctement une question et optimiser vos chances d'obtenir des réponses, pensez à lire le règlement CS, celui-ci pour bien poser votre question ou encore celui-ci pour les PFE et autres exercices.[*]Quand vous postez un code, merci d'utiliser la coloration syntaxique (3ième icône en partant de la droite : ).[*]En VB.NET pensez à activer Option Explicit et Option Strict (propriété du projet) et à retirer l'import automatique de l'espace de nom Microsoft.VisualBasic (onglet Références dans les propriétés du projet).[*]Si votre problème est résolu (et uniquement si c'est le cas), pensez à mettre "Réponse acceptée" sur le ou les messages qui vous ont aidés/list
---

Merci NHenry 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources a aidé 100 internautes ce mois-ci

Commenter la réponse de NHenry
Messages postés
12371
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
11 décembre 2018
3
Merci
tu mets
return null;

dans la clause catch et tu n'auras plus l'erreur

Whismeril

Merci Whismeril 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources a aidé 100 internautes ce mois-ci

Commenter la réponse de Whismeril
Messages postés
51
Date d'inscription
lundi 2 mars 2009
Dernière intervention
5 octobre 2015
0
Merci
Merci NHenry

Seulement avez vous une idée de comment désactiver l'option
J'utilise le ED Visual studio 2010

Merci
Commenter la réponse de levotre123
Messages postés
51
Date d'inscription
lundi 2 mars 2009
Dernière intervention
5 octobre 2015
0
Merci
Merci Whismeril et NHenry problème résolut avec succès
Commenter la réponse de levotre123
Messages postés
12371
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
11 décembre 2018
0
Merci
Tres bien, clique sur "réponse acceptée" ainsi la discussion apparaitra résolue.


Whismeril
Commenter la réponse de Whismeril

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.