Débuggage avec elevation de privilège [Résolu]

Messages postés
1293
Date d'inscription
mardi 28 octobre 2003
Statut
Contributeur
Dernière intervention
3 juillet 2015
- - Dernière réponse : sp40
Messages postés
1293
Date d'inscription
mardi 28 octobre 2003
Statut
Contributeur
Dernière intervention
3 juillet 2015
- 12 avril 2013 à 12:25
Bonjour,

Je suis sur une petite appli pour contrôler une panoplie de services windows.
J'ai fait un test avec le code de Damien (http://www.delphifr.com/codes/GERER-SERVICES-WINDOWS-AVEC-WINSVC_40408.aspx).
Problème, sous Windows7, le code utilisé nécessite une élévation de privilège pour fonctionner. Je l'exécute en mode administrateur, et tout va bien. Mais en debug, l'élévation de privilège ne m'est pas demandée et du coup, rien ne marche. Ce n'est pas vraiment pratique... Existe-t'il un moyen d'indiquer au compilateur que le programme nécessite une élévation de privilège lors du debug en pas à pas ?

Simon
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
1293
Date d'inscription
mardi 28 octobre 2003
Statut
Contributeur
Dernière intervention
3 juillet 2015
17
3
Merci
Bon désolé... j'ai trouvé. Il suffit d'exécuter Delphi en admin (clic droit, exécuter en tant qu'administrateur)

Simon

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 99 internautes nous ont dit merci ce mois-ci

Commenter la réponse de sp40

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.