Aucun enregistrement n'est ajouté à la table

Signaler
-
 snaibya1 -
Bonjour tout le monde,

J'ai créé une base de données avec les tables (TblProduct, TblTransaction, ...etc), mais quand je fais le test d'ajout d'enregistrement (voir exemple en dessous), je constate qu'aucun élément n'est ajouté à la table,

Merci de m'aider à trouver une solution sachant que je suis un simple débutant dans c#

************************************************************************************************************************

{
public partial class Form1 : Form
{
public Form1()
{
InitializeComponent();
}

private void button1_Click(object sender, EventArgs e)
{
CoffeShopDatabaseEntities csde = new CoffeShopDatabaseEntities();
TblProduct Product1 new TblProduct() {Description "Large Coffee"};
csde.AddToTblProducts(Product1);
csde.SaveChanges();
}
}
}

**********************************************************************************************************************************************************

Meilleures salutations

2 réponses

Messages postés
355
Date d'inscription
mercredi 13 avril 2011
Statut
Membre
Dernière intervention
15 juin 2019
10
{
public partial class Form1 : Form
{
public Form1()
{
InitializeComponent();
}

private void button1_Click(object sender, EventArgs e)
{
CoffeShopDatabaseEntities csde = new CoffeShopDatabaseEntities();
TblProduct Product1 = new TblProduct
{Description = "Large Coffee"};
csde.AddToObject(Product1);
csde.SaveChanges();
}
}
}

La Science est Grande et Vaste partageons cette connaisance
Merci beaucoup pour ton support, mais quand je fais les modifications suggérées ce message d'erreur apparait :
<<< Erreur 1 Aucune surcharge pour la méthode 'AddObject' ne prend d'arguments 1>>>
j'ai utilisé AddObject parce que AddToObject n'existe pas chez moi (J'utilise VS 2010 Ultimate, dernière mise à jour)
Salutations