Problème Icône

Sceyllia
Messages postés
8
Date d'inscription
mercredi 8 août 2007
Statut
Membre
Dernière intervention
21 mars 2013
- 21 mars 2013 à 21:26
cs_MAURICIO
Messages postés
2106
Date d'inscription
mardi 10 décembre 2002
Statut
Modérateur
Dernière intervention
15 décembre 2014
- 22 mars 2013 à 10:50
Bonsoir à tous,

J'aurai voulu savoir si il était possible sur Delphi d'avoir des icônes avec un contour net.
Car lorsque je compile j'ai un résultat qui laisse franchement à désirer.

Comme une image vaut mieux qu'un long discours, voici le problème visuellement parlant :



On peut constater qu'à droite c'est pas très propre (sorte de bavures sur les contours) alors qu'à gauche c'est parfait.

Sans me mâcher le travail une âme généreuse pourrait-elle m'éclairer ? S'agit-il d'un problème de transparence, de bits ?

Je précise (pour la compréhension c'est important) que l'image de droite vient d'un logiciel et qu'à gauche j'essaie
d'avoir le même résultat mais sans succès visiblement.

Comme ce programme a été programmé en Delphi je ne comprends pas pourquoi je n'arrive pas à obtenir le même résultat.

Grand merci à celui ou celle qui aura la gentillesse de bien vouloir m'aider.

Excellente soirée à vous tous.

2 réponses

Sceyllia
Messages postés
8
Date d'inscription
mercredi 8 août 2007
Statut
Membre
Dernière intervention
21 mars 2013

21 mars 2013 à 21:32
Oups ! le gars ne connait plus sa droite ni sa gauche

Donc : à droite c'est nickel, à gauche c'est pas très jolie c'est mieux je crois là...

Désolé pour cette erreur (la fatigue sans doute)

Merci encore.
0
cs_MAURICIO
Messages postés
2106
Date d'inscription
mardi 10 décembre 2002
Statut
Modérateur
Dernière intervention
15 décembre 2014
5
22 mars 2013 à 10:50
Salut,

pour avoir un résultat net, il faut utiliser les *.png!
Alternativement, tu peux retravailler les contours du bitmap.

a+


Composants Cindy pour Delphi
Faites une donation.
0