Demande d'aide [Résolu]

Signaler
-
 viftro -
Bonjour

Je suis entrain de programmer une application de Gestion ,bien voila :j'ai deux tableau MsfleXGird et une base de donnés acces 1 dataenvirenement 2 datareports , quand j'essaie d'imprimer des données nouvellement enregistrer sur la base on me donne pas d'erreur Mais tous ce que je reçoit sur le datareport c'est les anciennes données pas de mise à jour j'espère bien trouver une solution ????

7 réponses

Messages postés
18038
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
239
Bonjour,
Le Datareport ne peut prendre en considération les données modifiées que si le jeu d'enregistrement est reconstitué après les modifs.


________________________
Réponse exacte ? => "REPONSE ACCEPTEE" facilitera les recherches.
Pas d'aide en ligne installée ? => ne comptez pas sur moi pour simplement répéter son contenu. Je n'interviendrai que si nécessité de la compléter.
Messages postés
18038
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
239
Par ce que j'ai dit dans mon précédent message, j'entends par vérification, celle à faire alors que ton appli tourne encore, juste avant l'utilisation du datareport.


________________________
Réponse exacte ? => "REPONSE ACCEPTEE" facilitera les recherches.
Pas d'aide en ligne installée ? => ne comptez pas sur moi pour simplement répéter son contenu. Je n'interviendrai que si nécessité de la compléter.
Messages postés
14008
Date d'inscription
samedi 29 décembre 2001
Statut
Modérateur
Dernière intervention
28 août 2015
76
Salut

Tous nos voeux t'accompagnent.
Que veux-tu qu'on te dise ...

Vala
Jack, MVP VB
NB : Je ne répondrai pas aux messages privés

Le savoir est la seule matière qui s'accroit quand on le partage (Socrate)
Je vois pas comment puis je le faire sur dataenvirenement puisque la cmd .refresh ne fait rien
[^^confus2][^^confus2][^^confus2][^^!1]
Messages postés
18038
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
239
Dis-nous. As-tu au moins vérifié (dans ta base même, donc) que tes modifs y avaient été réellement faites ?


________________________
Réponse exacte ? => "REPONSE ACCEPTEE" facilitera les recherches.
Pas d'aide en ligne installée ? => ne comptez pas sur moi pour simplement répéter son contenu. Je n'interviendrai que si nécessité de la compléter.
oui bien sur ça s'affiche sur MSFlexGird que c'est Modifié et aussi quand je supprime un enregistrement mais c'est dans le Datareport que ca se passe même quand j’essaie de supprimer l'enregistrement rest afficher sur Datareport mais pas sur le tableau flex