Un bouton submit rebèle [Résolu]

Signaler
Messages postés
39
Date d'inscription
lundi 26 mars 2012
Statut
Membre
Dernière intervention
8 février 2013
-
Messages postés
39
Date d'inscription
lundi 26 mars 2012
Statut
Membre
Dernière intervention
8 février 2013
-
Bonjour,

J'utilise Jquery Mobile depuis quelque temps et je rencontre un souci etrange:

J'ai un formulaire de recherche, tout ce qu'il y a de plus simple, avec un bouton submit qui doit me diriger vers 'resultat.php'.

Mon problème est que, lorsque l'utilisateur click sur 'submit' : l'adresse url devient bien '...resultat.php' sauf que sur la page ... rien ne se passe.

Je n'ai aucune idee d'ou vient ce souci

help

merci

3 réponses

Messages postés
39
Date d'inscription
lundi 26 mars 2012
Statut
Membre
Dernière intervention
8 février 2013

Pour ceux qui auraient le même problème, un mec trop fort à trouvé (moi ).

si des erreurs de chargement se montre sur vos liens (formulaire également) il suffit d'ajouter data-ajax="false" dans la balise. Mon exemple :
<form action="onsenfou.php" data-ajax="false">


voila

bon courage
Messages postés
130
Date d'inscription
lundi 11 janvier 2010
Statut
Membre
Dernière intervention
7 juin 2013

Bonjour,

Le problème c'est que si tu ne nous montre pas ton code (php), on ne pourra pas deviner la/les erreurs^^
Messages postés
39
Date d'inscription
lundi 26 mars 2012
Statut
Membre
Dernière intervention
8 février 2013

Mon code page initiale :

<html>
<head>
<meta name="apple-mobile-web-app-capable" content="yes" />
<link rel="apple-touch-icon" href="img/iconipad.ico"/>
<meta name="viewport" content="width=device-width, initial-scale=1.0; maximum-scale=1.0">
<script src="http://code.jquery.com/jquery-1.8.2.min.js"></script>
<script src="http://code.jquery.com/mobile/1.2.0/jquery.mobile-1.2.0.min.js"></script>
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<!-- du code qui n'a rien a voir -->
<form action="resultat.php" method="POST">


<!-- la recherche se fait avec la touche entrée mais le problème persiste avec un bouton submit -->
</form>


et voila le code de 'resultat.php' :

// l'entete est la meme que celle de ma page initiale
$recherche=$_POST["recherche"];

mysql_connect('localhost','$user','$pass');
mysql_select_db('$datab');

$req='select * from lien where nomlien like "%'.$recherche.'%"order by numPosition limit 0,12';
$res=mysql_query($req);
// blablabla je vous passe le reste du code qui fonctionne sans souci