Mot de passe access sur Adotable [Résolu]

- - Dernière réponse : cs_walidlam
Messages postés
111
Date d'inscription
lundi 30 mai 2011
Statut
Membre
Dernière intervention
29 avril 2013
- 3 févr. 2013 à 12:20
salut
j'ai proteger mon fichier .mdb, par un mot de passe.
avec mon programme delphi, je voulai connecter mon fichier j'ai mis :

Provider='Microsoft.Jet.OLEDB.4.0;Data Source=C:\test\test.mdb;Persist';
Session.AddPassword('1234');
AdoTable1.Active:=true;

ca marche pas, un petit coup de main s.v.p
merci
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
111
Date d'inscription
lundi 30 mai 2011
Statut
Membre
Dernière intervention
29 avril 2013
1
3
Merci
salut!!
utiliser les évènements exemple:
procedure TForm1.ADOConnection1BeforeConnect(Sender: TObject);
var chemindb,passdb:string;
begin
chemindb:='C:\test\test.mdb';
passdb:='1234';
ADOConnection1.ConnectionString :=
    'Provider=Microsoft.Jet.OLEDB.4.0;User ID=Admin;Data Source='
    + CheminDb
    +';Mode=ReadWrite;Extended Properties="";Jet OLEDB:System database="";Jet OLEDB:Registry Path="";'
    +'Jet OLEDB:Database Password='+passdb
    +';Jet OLEDB:Engine Type=5;Jet OLEDB:Database Locking Mode=1;'
    +'Jet OLEDB:Global Partial Bulk Ops=2;Jet OLEDB:Global Bulk Transactions=1;Jet OLEDB:New Database Password="";'
    +'Jet OLEDB:Create System Database=False;Jet OLEDB:Encrypt Database=False;'
    +'Jet OLEDB:Don''t Copy Locale on Compact=False;'
    +'Jet OLEDB:Compact Without Replica Repair=False;Jet OLEDB:SFP=False';
end;

dans l'evenement du fiche ou datamodule oncreate

ADOConnection1.Connected:=true;


@+

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 193 internautes nous ont dit merci ce mois-ci

Commenter la réponse de cs_walidlam
0
Merci
merci ca marche tres bien
Commenter la réponse de nounou27000
Messages postés
111
Date d'inscription
lundi 30 mai 2011
Statut
Membre
Dernière intervention
29 avril 2013
1
0
Merci
salut!!
penser a cliquer sur Réponse acceptée
@+
Commenter la réponse de cs_walidlam