Probleme compilation netBeans [Résolu]

Messages postés
76
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
2 août 2018
- - Dernière réponse : eccsup
Messages postés
76
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
2 août 2018
- 6 déc. 2012 à 11:27
Bonjour a tous,

Je rencontre un probleme assez... spécial avec mon netbeans, et vous pourrez peut-etre m'aider.

J'ai un projet WEB a faire gerer par Maven, gerant un Site Web, accompagne d'une base de données, ainsi, j'ai créer un classe Java (Executable) pour initialiser ma BD, mais lorsque je demande a NetBeans d'executer ce fichier, il m'affiche l'erreur suivante:

'"C:\Program Files\NetBeans 6.9.1\java"' n'est pas reconnu en tant que commande interne
ou externe, un programme ex‚cutable ou un fichier de commandes.
[ERROR]The following mojo encountered an error while executing:
[ERROR]Group-Id: org.codehaus.mojo
[ERROR]Artifact-Id: exec-maven-plugin
[ERROR]Version: 1.1.1
[ERROR]Mojo: exec
[ERROR]brought in via: Direct invocation
[ERROR]While building project:
[ERROR]Group-Id: prosper
[ERROR]Artifact-Id: prosper
[ERROR]Version: dev
[ERROR]From file: C:\Users\Tanguy\Documents\NetBeansProjects\prosper\prosper\prosper\pom.xml
[ERROR]Reason: Result of cmd.exe /X /C ""C:\Program Files\NetBeans 6.9.1\java" -Xdebug -Xrunjdwp:transport=dt_socket,server=n,address=53486 -classpath C:\Users\Tanguy\Documents\NetBeansProjects\prosper\prosper\prosper\target\classes;C:\Temp\m2repo\org\jasig\cas\client\cas-client-integration-jboss\3.2.1\cas-client-integration-jboss-3.2.1.jar;C:\Temp\m2repo\commons-logging\commons-logging\1.1\commons-logging-1.1.jar;C:\Temp\m2repo\javax\servlet\servlet-api\2.3\servlet-api-2.3.jar;C:\Temp\m2repo\org\jasig\cas\client\cas-client-core\3.2.1\cas-client-core-3.2.1.jar;C:\Temp\m2repo\org\hibernate\hibernate\3.2.5.ga\hibernate-3.2.5.ga.jar;C:\Temp\m2repo\net\sf\ehcache\ehcache\1.2.3\ehcache-1.2.3.jar;C:\Temp\m2repo\commons-collections\commons-collections\2.1.1\commons-collections-2.1.1.jar;C:\Temp\m2repo\javax\transaction\jta\1.0.1B\jta-1.0.1B.jar;C:\Temp\m2repo\asm\asm-attrs\1.5.3\asm-attrs-1.5.3.jar;C:\Temp\m2repo\dom4j\dom4j\1.6.1\dom4j-1.6.1.jar;C:\Temp\m2repo\antlr\antlr\2.7.6\antlr-2.7.6.jar;C:\Temp\m2repo\cglib\cglib\2.1_3\cglib-2.1_3.jar;C:\Temp\m2repo\asm\asm\1.5.3\asm-1.5.3.jar;C:\Temp\m2repo\org\hibernate\hibernate-entitymanager\3.3.2.GA\hibernate-entitymanager-3.3.2.GA.jar;C:\Temp\m2repo\org\hibernate\hibernate-annotations\3.3.1.GA\hibernate-annotations-3.3.1.GA.jar;C:\Temp\m2repo\org\hibernate\hibernate-commons-annotations\3.0.0.ga\hibernate-commons-annotations-3.0.0.ga.jar;C:\Temp\m2repo\org\hibernate\ejb3-persistence\1.0.1.GA\ejb3-persistence-1.0.1.GA.jar;C:\Temp\m2repo\javassist\javassist\3.4.GA\javassist-3.4.GA.jar;C:\Temp\m2repo\org\hibernate\hibernate-validator\4.3.1.Final\hibernate-validator-4.3.1.Final.jar;C:\Temp\m2repo\javax\validation\validation-api\1.0.0.GA\validation-api-1.0.0.GA.jar;C:\Temp\m2repo\org\jboss\logging\jboss-logging\3.1.0.CR2\jboss-logging-3.1.0.CR2.jar;C:\Temp\m2repo\javax\sql\jdbc-stdext\2.0\jdbc-stdext-2.0.jar;C:\Temp\m2repo\postgresql\postgresql\9.1-901.jdbc4\postgresql-9.1-901.jdbc4.jar;C:\Temp\m2repo\org\eclipse\persistence\eclipselink\2.3.2\eclipselink-2.3.2.jar;C:\Temp\m2repo\org\eclipse\persistence\javax.persistence\2.0.3\javax.persistence-2.0.3.jar;C:\Temp\m2repo\org\hibernate\hibernate-core\4.1.8.Final\hibernate-core-4.1.8.Final.jar;C:\Temp\m2repo\org\jboss\spec\javax\transaction\jboss-transaction-api_1.1_spec\1.0.0.Final\jboss-transaction-api_1.1_spec-1.0.0.Final.jar;C:\Temp\m2repo\org\hibernate\javax\persistence\hibernate-jpa-2.0-api\1.0.1.Final\hibernate-jpa-2.0-api-1.0.1.Final.jar;C:\Temp\m2repo\org\javassist\javassist\3.15.0-GA\javassist-3.15.0-GA.jar;C:\Temp\m2repo\org\hibernate\common\hibernate-commons-annotations\4.0.1.Final\hibernate-commons-annotations-4.0.1.Final.jar prosper.DatabaseCreator" execution is: '1'.

si qqun sait comment resoudre ce probleme, ou seulement quel en est la cause, je suis ouvert a toute proposition.
Afficher la suite 

2 réponses

Messages postés
76
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
2 août 2018
0
Merci
merci pour ta réponse,

En effet, j'ai copier coller la commande dans la console windows en remplaçant "C:\Program Files\NetBeans 6.9.1\java" par java.exe... et ça marche nikel... je sais pas pourquoi Netbeans a utiliser ça comme exécutable, mais du coup je fais les manœuvres manuellement
Commenter la réponse de eccsup
Messages postés
6413
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
17 mai 2018
246
-2
Merci
Salut,

Je suis assez étonné que java se trouve dans un sous dossier de netbeans, tu devrais plutot utiliser la JRE de ton système.

Et j'utiliserais java.exe et non java

PS :
je suis ouvert a toute proposition

Dans les limites de la bienséances j'espère
Commenter la réponse de cs_Julien39