Aucune source disponible

Signaler
Messages postés
34
Date d'inscription
vendredi 1 juillet 2011
Statut
Membre
Dernière intervention
11 février 2013
-
 Utilisateur anonyme -
salut à tous,je travaille actuellement sur projet en vb2010.
Je n'arrive pas à afficher mon formulaire à l'éxécution de mon programme.
voici l'erreur qu'on m'affiche:
Une erreur s'est produite lors de la création du formulaire. L'erreur est : Variable objet ou variable d'un bloc With non définie.

3 réponses

Messages postés
14008
Date d'inscription
samedi 29 décembre 2001
Statut
Modérateur
Dernière intervention
28 août 2015
80
Salut

Normalement, cette erreur te désigne la ligne que le compilo ne comprend pas : laquelle ?

Vala
Jack, MVP VB
NB : Je ne répondrai pas aux messages privés

Le savoir est la seule matière qui s'accroit quand on la partage (Socrate)
Messages postés
14823
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
9 octobre 2021
156
Bonjour,

Regardes la pile des appels (voir aussi dans le détail de l'exception).
Ensuite, repères la ligne en question et regardes quelle valeur est à Nothing.

---------------------------------------------------------------------
[list=ordered][*]Pour poser correctement une question et optimiser vos chances d'obtenir des réponses, pensez à lire le règlement CS, celui-ci pour bien poser votre question ou encore celui-ci pour les PFE et autres exercices.[*]Quand vous postez un code, merci d'utiliser la coloration syntaxique (3ième icône en partant de la droite : ).[*]En VB.NET pensez à activer Option Explicit et Option Strict (propriété du projet) et à retirer l'import automatique de l'espace de nom Microsoft.VisualBasic (onglet Références dans les propriétés du projet).[*]Si votre problème est résolu (et uniquement si c'est le cas), pensez à mettre "Réponse acceptée" sur le ou les messages qui vous ont aidés/list
---
Mon site

Bonjour,

Je ne suis pas sur que j'avais le même message d'erreur et je pourrais être dans le champ, mais d'un coup...

J'ai déjà eu ce genre de problème parce que l'ajout d'un contrôle s'était mal passé à cause d'une panne d'électricité au mauvais moment.

Il avait fallu que je fasse ce que Microsoft ne veut pas que l'on fasse. J'ai ouvert le "desinger" de la feuille et j'ai effacé toutes les lignes "parlant" du contrôle. Après j'ai pu afficher la feuille et réinstaller le contrôle. Mais comme je disais, je ne suis pas vraiment sûr que cela corresponde à ton problème.