Extraction de données à partir d'un fichier texte et les mettre dans une BD

Signaler
-
Bonjour à tous;
En développant une application web en PHP (et javascript pour les forms et les fenetres) j'ai besoin d'extraire des informations ,à partir d'un fichier de configuration des switch cisco, et les mettre dans une table dans ma base de donnée crée avec PHPMyadmin.
j'ai trouvée sur le net que je peut utiliser le script ciscoconfparse mais comment faire???
Pour mieux expliquer:
Par exp j'ai ce bout de fichier:
********************
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport nonegotiate
switchport voice vlan 20
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
switchport nonegotiate
switchport voice vlan 20
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
switchport nonegotiate
switchport voice vlan 20
spanning-tree portfast
!
**********************
je veux que dans ma base soit affiché les champs suivant:
Port: FastEthernet0/1
Mode:access
Vlan:10
et ainsi de suite...

merciii de me donner un coup de main
cordialement